WD Media Player - Issues with movies no longer appearing on my hard drive

I have recently been experiencing a problem where certain movies no longer show up on my media player menu.

I am using an older WD media player that is about 10 years old. It has worked fine until recently. I also have 2 WD 2TB hard drives (full of movies) hooked up to it.

The problem is once a movie is watched, it disappears from the menu screen. I can do a all files search and the move folder shows up but the actual movie file is gone.

I tried hooking up my hard drive to my computer and it shows the same thing, the original movie folder is there but the movie file is gone.

Any suggestions? Reasons to why this is all of a sudden happening?

I am afraid to watch movies now with fear after I watch them, they will no longer show up.

the old “converts files to folders” is a common problem that plagued all the wd tv media players.

You might find something in the search results link below, but personally i gave up using wd tv media players about 5 years ago and have been using a Raspberry Pi 3 which has been awesome with zero issues.


Ok thank you. I will look into it.