WD Live streaming m player compiling issues

Compiling media Library freezes : I have tried all the suggestions on the forum : From deleting the WD folder on the drive to reset it in setup to resetting to defaults to defragging and scanning drive for errors. Its a normal WD 1TB passport and rebuilding the media library freezes and hangs every time . It sees the folders but after 5 min it hangs. I am at a loss and this is the 2nd model tested. When u plug out the drive it takes a min and retuns automatically to the home screen. And its not that i am impatient - i left it on for 24 hrs a few times already. Any usefull suggestions please ? Could it be as result of other folders like documents etc being present on the drive? I forsee allot of units coming back through RMA if we cannot resolve these issues…

My theory as to why this happens for some people is that there’s at least one file that the WD totally chokes on.

I know it’s tedious, and the you should not have to do it, but try adding the media to the disk in small doses, and let it compile.

When it dies, you know that the “problem” file was added in the last dose, and by removing half of that does, and repeating until the problem clears, you can quickly narrow down what file is creating the problem.

well tony,

that was one opf my ideas what might cause the problem.

so i created a new folder on my NAS, and placed only one file (i tried avi, mkv and m4v) for each try inside the folder. so my media library had to compile the tremendous amount of ONE file - the result was always the same.

  • smp compiling 4ever
  • smp freezing after turning media library off and removing the share source

of course i deleted everytime the wdtv folder before i tried again with another movie file, and i also checked b4 that my smp played each file without any problems.

as a last test and to make sure that the files are NOT corrupted i copied them onto a usn-stick, plugged this stick into my NAS (NOT into the smp), so i could connect to it as another network-share. and this time compiling WORKED!!

so it’s quite obvious to me, that there has to be an issue when trying to compile the media library on a REAL NAS drive, and not with “maybe corrupted” video files.

cheers, pedrolino


I have 24 TB worth of NAS, in 6 or 7 different shares on 4 different hosts.

All of these are “Real NAS”.

In addition to that, I also connect from my SMP to my Live Hub, as well as my Win 7 PC’s shares.

I’ve done it with a mix of both SMB and NFS share protocols.

My box has no problems at all compiling well over 50,000 files (combined video, music, and photos.)

So it’s not as simple as “REAL NAS” having a problem.

You actually explained the difference in your own test.   You created a FOLDER, but was that folder in its own SHARE, exclusive of all other folders and all other shares?   If not, then you’re not ruling anything out.


I just read your ISSUE report on the same subject.

Quite frankly, if your NAS’s CPU is hitting 80-90% during media library compilation, your NAS may have a problem.

My NAS boxes CPU’s barely fluctuate during this process.  My WD MyBook Live NAS CPUs might go from 20% or so to 35%…  but that’s it…

If you’re comparing volumes on INTERNAL disks versus USB-attached NAS disks, and that’s fixing the problem, then that also indicates your NAS has an issue, because there’s no way the WD can tell the difference between volumes that are INSIDE the NAS versus volumes that are USB-attached to the same NAS.

From the WD’s point of view, they’re just a shared volume.