WD Live Plus not booting up


#1

Think I may have messed up my player.  Was trying to reset it like the forums said since it would no longer play any of my files. did it once unsuccessfuly (but I forgot to reset to factory default in the system.)  So I tried again, clicked the reset button twice on accident, now the system shows the WDTV Live Plus splash screen, flips off, then flips back on to a screen of snow. Will not load past this point.  Please help!


#2

Welcome to the forums.

Try unplugging it from power for at least 15 minutes and see if that then works.


#3

You may have inadvertently switched it to PAL instead of NTSC (or vice versa)

You can HOLD the reset button for 10 Seconds and see if that changes anything.  If it doesn’t, do it again to put it back where it was.

This is only if you’re using Component / Composite, not HDMI.

[edit:  I said “Power Switch,” it should have read “Reset Button.”  Fixed.]


#4

I’m an ■■■■■, thanks a lot, I had switched it somehow.  THanks!!


#5

No problem.  Glad you’re squared away.   If you could, please mark the post as SOLVED. :slight_smile: