WD live plus Hangs

Hey everybody,

Tried to find if this is out there already, but I could see no thread for this particular problem.

Cannot turn Box off with remote, have to unplug at the back.  When I plug it back in , it is on already.  I do not turn it on, it just goes right into Logo screen), and hangs there.  I have tried this a couple of times, as well as resetting…all to no avail.

any help would be greatly appreciated. Chers.


It’s normal behaviour for the box to turn on when you plug it in.

What do you have plugged into the box (Ethernet, USB drive, USB Wi-Fi Adapter, HDMI, Composite)?

Thanks for that, However it will not turn off when using remote.  At the moment I am running two usb connected harddrives, and ethernet. 

Any help you can give me would be great.



oh and it’s composite connection as well>>>>>

I’ve got the same problem and suspect it’s a common issue with this model. The unit won’t turn off with the remote and the only solution is to unplug it. The one exception is when the unit has been on for a short time, the remote will turn it off.

I’m using the most current firmware (the unit is not giving me an option to upgrade firmware, so I must be current). I use an HDMI cable to connect to the TV. There is nothing else plugged into the unit. It would be nice to know if others are experiencing the same and see if there is a solution.