WD Live Plus and Netflix Issue. Anyone else? *UPDATED*


#1

* UPDATE #2 *

 I took my Roku over to my friends house and set it up for them as a gift, I had the same issue with no sound from the Roku box as I did on the WD Live Plus: Sound was no working, I had to get out of the movie and try several times before it would work.

 I went home and tried watching some shows on my HTPC and laptop, same issue. I am on hold with Netflix right now to talk to them about the problem, so it looks like this is a Netflix problem and not WD Live issue.

=================================================================================

 I have everything setup right, I think,  connected to the TV via HDMI. The first time I play something in Netflix, there is no sound. This is really, really annoying. I have to first play something off my local USB Drive and then go into Nexflix and everything works fine.

 Anyone else seeing this? Maybe I am missing a menu setting somewhere.

* UPDATE *

 Ok, so I tried this unit on two different TVs with four different HDMI Cables. The results were the same. I then called the 1-800 number and got some REALLY BAD Outsourced non-help. The guy essentially told me that the product was new and I should pretty much go F#k myself since he had no idea what the problem might be.

 I hung up, tried again, and this time I was put on hold for about 10 minutes, and then told that if I was going to stream HD Video, I needed to use the digital out for audio. What? I was trying to watch a SD Episode of South Park, and a SD old movie (Where Eagles Dare).

 I hooked up the Component cables and everything works great on Netflix, but now I get no sound on my USB… so I guess when my other Plus gets in, I will see if the issue with HDMI is on both boxes. Eventually I managed to get sound to work on Netflix and other media by putting the Video to 720p.

PRO-TIP: For whatever reason, the Netflix stream will default to 4:3, regardless of the settings on the WD. My TV was set to


#2

I was here looking into issues with my 5 hour old WD TV LIVE PLUS box. I hooked it all up tonight and linked etc… I can see all of my Netflix que but when I hit play it flashes 2 “retrieving” the movie screens and then nothing happens. No sound, no picture… Nada

I have to exit out and go back in the menu. I then hooked up my Roku HD box and everything worked perfectly. I rebooted the router and the LIVE PLUS to no avail. Netflix is working in my PC and ROKU but LIVE PLUS is dead in the Netflix water. Maybe one of us will find the answers to these issues! Good Luck!

Chad