WD Live No Longer Recognizes WD My Book 4 TB

Hello All,

I know that many of you are thinking “we’ve already answered this a hundred times in other threads; why can’t someone just do the work and research and read them.” I promise I have spent more than three hours reading threads on this community about my problem and have tried all the solutions given and I still can’t get it to work.

My brother brought down his WD Live Streaming Media Player down along with one of his WD My Book 4 TB external hard drives (not a cloud one). He told me that it was in his daughter’s room and they had watched a movie (The Good Dinosaur) on it. Ejected the My Book; turned the WD Live off; took it out to his living room; plugged the WD Live and turned on; plugged the My Book and it said it was connecting but after several minutes nothing. He tried to eject, but nothing. Nothing under file. Turned it all off and tried again and again stated it was connecting to USB Storage and nothing again.

He brought it to me and we tried on my WD Live and again it stated it was connect to USB Storage, but after 30 minutes, still nothing was read. Nothing was there to eject. I disconnected the My Book and plugged into my computer and it read just fine. I could see and manipulate all movie files. I then began researching and found a thread that suggested turning the WD Live off; plugging the My Book into the computer and turning on the hidden files and deleting the .wd_tv file; ejecting from computer and plugging the My Book back into the turned off WD Live; turn on the WD Live and wait for everything to run and boot up. I did all of this waiting a long time and still nothing. I did not even say that it was trying to connect to a USB Storage Device. I then turned off the WD Live; unplugged the My Book; turned on the WD Live; waited for the WD Live to boot up; plugged in the My Book. The WD Live stated again the it was connecting to the USB Storage Device but after a long time, nothing. I will mention that the My Book light blinks a few times and then stays completely lit. I will also mention that my WD My Book works on both WD Lives with no problems.

So, my brother’s WD My Book does not work on two different WD Lives, but is seen by a computer.
His WD Live is able to connect with my WD My Book.
I have deleted the file .wd_tv and it still has not been put back on the My Book.

Is there anything that I am not thinking of or have not been able to find in another thread. Any suggestions would be helpful.

Thank you in advance. And please let me know if there is any further information you need from me.


did you run a windows “chkdsk” on the drive ? that’s the 1st thing i always advise

Thank you for answering. No I did not. And to be honest, I don’t know how. Could you please tell me where to go to do that?

you can run it from windows or command line

for more info …gOOgle is your friend

1 Like


Thank you so very much. I googled “how to run chkdsk” and pulled up the MicroSoft page and ran the command (twice actually) and ta da!!! It worked like a champ. I can’t tell you thank you enough!!!

Your welcome :slight_smile: