WD Internal Hard Drive Fixing Help


#1

I have a really weird problem with my WD internal hard drive. I built my pc, ASUS PRIME Z370-P motherboard, 650-watt power supply, 8700 i7 CPU, 1060 Asus graphics card and Samsung 970 250 gigs for my rig. Its fast, and I needed more space to store my games. That is why I bought the WD hard drive 1 terabyte along with the pc parts and fixed it up. Note: This was 4 months ago.

After being really busy, and occasionally being able to play on the rig and did not set up the WD, but over winter break, when I had free time and was trying to download new games(Battlefront 2 Starwars), I discovered that I did not have enough space to put it in, and was surprised to realize that I put it on the SSD(which I only reserve for things like Windows). So I uninstalled all my games and tried to put it into my hard drive to discover that
MY HARD DRIVE WASN’T SHOWING! I tried everything, I went to the disc manager, but not even the unallocated space did not show up for the hard drive, so it was not a problem with initializing it. Additionally, it shows up in bios and in device manager. However, when I try to see the volume for the hard drive NOTHING SHOWS UP!
I have tried changing the SATA cable a reconnecting and disconnecting, resetting bios to default.
Do you guys have any advice? Is it not working because I did not do this when I first bought this???
Thanks, plz help quick!


#2

You should start to use your HDD after reformatting in supported file format. If it is asking to initialize, indicates that partitions has not been set up and need to use after creating the new partitions.