WD Internal 1TB Desktop Hard Drive Not Recognized


#1

Hello, I have recently bought a WD 1TB SATA hard drive. But, for some odd and strange reason, it’s not being detected by my BIOS or Windows 7.

Any ideas on why this might be happening?


#2

Hi,

How many cables are coming from the back of the HDD??

Do you have a SATA Power Cable goin’ in along with the Data Cable??

ShiV


#3

Same problem here, mine worked for a day. I moved my files from my c drive to the 1TB hard drive. The next day it was no longer recognized by my BIOS, Windows XP, Windows 7, Popcorn Hour and my nexstar dock . All other sata drives are recognized. Any solutions? I don’t want to lose the content on that drive.

1TB

WD1001FALS


#4

No solutions?


#5

Both power and SATA cables are plugged into the hard drive - Still no sign of… well anything


#6

I’m having the same problem. I have the newest BIOS (5 months old). Tried everything, removed other SATA drives, jumpered 1.5Gbs. Nothing works. Not happy. Anybody have ANY ideas?


#7

Same issue here. Bought a WD Caviar Black 1TB drive. There are no jumpers. Using SATA power cable and SATA data cable connected to SATA2 on the motherboard. My system drive is on SATA0 and the BD/DVD drive is on SATA1.

If I disconnect this drive and instead connect my WD2500KS to the cables, the system recognizes the drive. I need 1TB in there, not 250GB.

I’ve tried different jumper settings, tried plugging into SATA3, nothing brings the drive to life, even though I can tell it is spinning.

What are my options? My system drive is a Seagate 1TB EOM. I’d rather stick with WD, but this is quite frustrating.


#8

hi,

for SATA drive no need set any jumper. have you check WD 1TB in others computer for make sure it work in good condition? remove all SATA drive. just connect with WD 1Tb. and change cable for try.