WD HD Live Doesn't Recognize WD Element HDD (IS IT JOKE?)


#1

hi,

i bought an wd elements 1tb hdd and try to use it with my wd hd tv live. Device never recognize my hdd. restoring to defaults, deleting wd files didn’t work…

I can use hdd with my pc and also I can use wd hd tv live with WD myBook…

I look at the list below and my new hdd is defined…

What is the problem with this device?


#2

What type of file system did you put on it? Do you have anyother USB devices plugged in to the WDTV Live when you plug in the HDD?


#3

there is no other usb device on WD HD TV LIVE…

my element’sfile system is ntfs


#4

When you plug it into the WDTV Live does the HDD spin up?


#5

yep i can use hdd at my pc…


#6

At this point I have to ask some stupid questions. Are you using the same power adapter at both places? Are you using the same USB cable? Have you tried a full - not quick - format on the drive after removing the partition and recreating it?

Sorry these seem a bit lame, but at this point, I have no idea. WDTV can be a bit touchy sometimes when a drive is disconnected improperly and I have had a problem with a brand new Passport drive that was solved by deleting the partition and then doing a FULL format of the drive. Outside of that, you may want to try another drive… There is always the (very very very slim) possibility that the drive is defective in some way.


#7

Try reformatting the drive and see if it works after that.