Wd firmware updater : the specified drive is in use

  • Ran the WD smartware
  • Told about the firmwqre update
  • downloaded & unpacked it
  • Ran the update

“The sepcified drive is in use : please exist the other applicaitons and retrying”

I am running Vista and MS Security Essentials, which you can’t turn off - but you can stop it scanning the external drives.

The problem was… the WD smartware which has no (obvious) option to disable or unload.

the fix?

Right click on My Computer and choose Manage, find the Services tab, look for the three WD services, shut them down, then retry the firmware update.

It worked perfeclty.

Probably a bit involved for anyone who’s not a windows geek to fix though… I’m giving your software release team a 4/10 for this one.

1 Like

At least it worked for you, so thanks for sharing!

when you turned the services back on, did the update have any adverse affect on the smartware’s function?

Hi guys,

I too had no success until I removed and replaced the USB lead.

(BTW…  Mybook 3Tb, August 2011, HP computer, XP Pro, USB 2 socket)

So, building on what everyone has said,  my checklist reads as:

WD Updating Firmware Error

If when updating firmware you get:

'The specified drive is in use. Please click Exit, then close all other open applications and run the WD Firmware updater again.

Order to try…

Antivirus off etc

Check Smartware version. Apparently there may be differences
 between models e.g. Passport and Mybook.

Go to Services

Find the 3 WD services:
WDDMService.   
“C:\Program Files\Western Digital\WD SmartWare\WDDMService.exe”
WDFMEService.   
“C:\Program Files\Western Digital\WD SmartWare\WDFME.exe”
WDRulesService   
“C:\Program Files\Western Digital\WD SmartWare\WDRulesEngine.exe”

Stop the service for each of them

  1. Unplug the USB cable. Wait 20 secs and plug in again.

  2. Try running the updater again.


Hope that may help someone.  :smileyvery-happy:

Pete

Error updating WD Firmware.jpg