WD External Drive - Needs Formatting after 1 yr of use - Lost data

I was hoping someone could help me!! Basically Windows can no longer read the contents of my WD external drive - which I have connected to my Dell computer. I have used this external hard drive for over a year and never had issues with it before now.

The harddrive itself still spins up as it should, and it still shows up on my Disk Management screen (with “RAW” as the File System setting… instead NTFS/Fat16/32 ), but Windows can’t access any of the files inside the drive, and it only shows up as “Local Disk (H )” in the My Computer folder.

Whenever I try to open it, the computer takes about a minute or two, then tells me the drive “needs to be formatted” before Windows can use it,

So I need to convert RAW to NTFS without formatting data.

Any help would be greatly appreciated, as I need to access this data.

It seems to be that the partition of the drive is corrupted… you can try with a data recovery software to get the inforamation out of the drive and then you can write zeros on the unit and create a new partition.

I have exactly the same problem, no issues at all until now.

You can feel the drive humming as always, so it is getting power.

I tried some data recovery software, but it cant access drive either. I can keep going and downloading other data recovery software but i dont believe that is going to help me.

I have been looking at this issue for the last 2 days, there are a HUGE number of people identifying this same problem. What is going on here?

Am I to understand that my only option is to send this out to a data recovery place, that I’ve already priced out 8 months ago with an internal hard drive on older laptop at $1,000 and no guarantees of anything? This is crazy. I’m starting to think I need to completely reassess how I store data and go to online storage or even back to dvds (a lot of them).

Try downloading a Linux Live ISO and burn the CD and boot from that and see if that will access the drive. It doesn’t actually install on your system and sometimes allows access to recover files. Sometimes running the command prompt  to convert FAT32 to NTFS will also ffix a Raw drive http://support.microsoft.com/kb/214579  Run as administrator the prompt is about halfway down.


Eventually, I fixed the problem by updating WD firmware to the USB3.0 mypassport 1TB HDD.

  description of my probllem faced >>>
 After >1yr3months using mypassport USB3.0 1TB HDD, I begin to face problem with mypassport HDD, it intermitently shows “delayed write failed” and then not readable by WinXP … I frustrated, quick formated the HDD, begin to copy data to this WD HDD, it works fine till about 270GB data content stored in HDD, then everytime shows error “delayed write failed” when u connect it to USB2 port. Then, I tried to re-format HDD without “quick format” option clicked. However, it failed to re-format, and only the  “Device Manager”  abe to recognise mypassport HDD , and window explorer & computer management — disk management cannot recognize the HDD, eventually the problem fixed & resolved by updating the WD firmware to the USB3.0 mypassport HDD.