Wd ex2 ultra dont recognizes disk 2

Hello guys
I have a WD EX2 Ultra with a WD Red 6TB & WD 3TB inside , unfortunately whan I was trying to format the 3TB disk there was an electric power failure.
Since then the NAS report that the disk is BAD and dont recocnizes it , I put it in my PC and format it and works perfect but when i put it again in the NAS and trying to create a new volume the same result BAD disk ???
Any help is highly appreciated, thank you in advance

See the dedicated subforum for the EX Series of devices. You can move your post/thread to that subforum where users more familiar with the EX2 Ultra may be able to assist.

OS5 EX Series

As a troubleshooting step, if you haven’t tried already, put the problematic hard drive into a PC and remove all partitions on it, then create a new single partition the size the the entire hard drive capacity, then format the partition for NTFS. Then try putting it back into the EX2 Ultra enclosure and see if the EX2 Ultra recognizes the drive and will properly format it for use.

Hi Bennor
thank you for the help but I have done that 3-4 times unfortunatelly without any result when I insert the disk checking the storage space it says good when I’m trying to create a new volume in the NAS the result is BAD ???

Which firmware on EX2?