WD Elements portable drives nog opening (anymore) on MAC

Hi guys,

We’ve been using our external WD Elements drives (4 + 5TB) for the past 8 years and use them on our MAC and Windows laptops. A while ago the drive didn’t appear on our Mac anymore. So we figured out, first connect the drive to the windows pc, disconnect and after we could connect it to the macbook.

After some time this ‘trick’ stopped working and we had to go to the disk utility program and use the first aid to activate the drive. This also worked for some time. But unfortunately we ran out of tricks to start the drives on our macbook. The drive is still visible in in the Disk Utility program, the first aid doesn’t show any problems, but it simply won’t show or start.

We tried installing the WD Drive Utilities software, but it doesn’t find our drive (eventhough it’s vissible in the Disk Utility Program). The drives are still working, since we can access them without any problems on our windows laptop.

We have 2 different Mac’s and we tried different versions, we are currently working with ‘Ventura’.

Anyone have a clue what’s going on?



Hi @Erik4 ,
Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Thanks for the details, just contacted the support team. Fingers crossed.