WD Elements Not Mounting But Visible in Disk Utility - Help!

Hi everyone, 

I’ve googled this extensively but not really worked out what to do.  Basically my 2  year old WD Elements 1TB Drive is not being recognised when I plug it into my Macbook Pro.  It tells me it is not readable and gives me the option to ignore it, eject it or initialize it.  I tried ignoring it, but then it doesn’t show up in Finder.

It does however show up in Disk Utility.

I’ve tried replacing the power supply and the USB cable, but this has not helped - same problem.  I’ve also tried connecting it to Windows PCs, but it doesn’t show up there either.

I have moved my entire iMovie library onto this drive alongwith other important things, so I am really desperate to get to the contents of it.

I am struggling to know the best way to go about recovering the files on there, and I don’t have the budget to take it to a data recovery place.

Can anybody please offer any instructions to help??

Any info really, truly, greatefully received…



The partition is corrupted.

Try running first aid and see if that will fix the partition.

If that does not work, you will need to use a recovery software to get the files and then initialize and format to continue using it.

1 Like

Thanks for the help Wizer,

I tried to run disk repair on the highlighted disk in the image (i’m not sure if that was the right thing to do) and I got the error message shown on the image below.

Any thoughts on what else I could attempt - are you aware of any specific software for example that could deal with this error message?

Thanks again for your help.



You can use Mini Tool data recovery or any other software to retrieve the files

1 Like

Thanks so much Wizer, I am trying that out now, it looks really simple to use…

Really appreciate the recommendation.

All the best