Wd elements messed up


#1

Hey I bought a wd elements external 1.5TB HDD 3-4 months ago and now when I tried to access it I can’t. If I try to do anything with it on my computer it will freeze until I pull out the cable(I know its not a good idea but IM desperate) where it will then try to do what I wanted it to do in the first place. I can see it listed in device manager but that’s also failed. I’m trying some data recovery software at the moment to scan the drive and see if it can find anything but nothing yet as the search time is tedious. What I have noticed is when I try to select the drive in any program it will freeze, but if I take the cable out and put it back in it unfreezes and I can do what I need to.

Any Help is welcome

Computer: Windows 7 laptop, also does same thing on My netbook

Edit: Ive tried to format it but i cant access the formating tools or options as it freezes


#2

Slow access is often a sign of hard drive failure, but it could just as easily be a power issue.  If you have a WD Elements Desktop drive, make sure it’s plugged directly into the wall and not a power strip.  If you have a laptop, make sure it’s plugged in to AC power as well.

Of course, if you have access to another computer, test the drive with that to make sure there’s no driver or configuration problem on your primary computer.

EDIT: Just realized I wasn’t clear, sorry.  :)  Yes, I did read that you tried it on your netbook, and assumed that had Windows 7 on it too.  If you have access to a computer with a different version of Windows, make sure to test the drive on one of those computers.  If your Netbook was running Windows XP or Linux or something, then we know it’s the drive.

In that case, you might want to check if another computer is faster.  If all else fails, you’ll be looking at data recovery if you don’t have backups of the data on the drive.  The drive should still be under warranty so we can get that replaced at least–so focus on your data for now.


#3

The netbook I tried it on had XP and did the same.

Same thing on my friends vista desktop.

I think it be a hardware fail so I’m going to try get another one

Thanks for the help