WD Elements external drive icon disappeared from desktop monitor?

I only just bought a 4TB WD drive a couple of months ago. I have been working on a film project and today I was transferring footage to the drive when the WD icon disappeared from my desktop monitor. I have not been able to find it and my iMac is not reading it. I tried connecting it to my laptop and still nothing.I have also used different power source and USB3 and still nothing.

I just re-tried it then and a message has come up on the screen that says: ‘The disk you inserted was not readable by this computer’. It has given me the option of ‘initialise’ ‘ignore’ or ‘eject’. Does anyone know why this is, what this means or how I rectify it? Also why this would happen? It has been working perfectly until now and it has 2 TB of information on the harddrive that I need.

Many thanks in advance for any help that is offered


I believe the partition is corrupted. If you need to recover the data then you can try a data recovery software.

thanks so much for your reply. Can you suggest a data recovery software?, I’ve never had to do this before.
Many thanks