WD Elements Desktop (10TB) not recognized by Mac

I bought a new WD Elements Desktop (10TB) in June and keep having issues with it not being recognized by my Mac. The issue is as follows:

  1. Either I connect the drive to power first and then connect the USB cable to my Mac, OR I connect the USB cable first and then the power. It does not make a difference, the issue occurs with both methods.
  2. I can see (white LED) and hear the drive turning on, the HDD starts spinning.
  3. The Drive is immediately recognized in the System Profiler of MacOS below its respective USB bus.
  4. HOWEVER, it never shows up in disk utility, and with that obviously also not in finder. It’s “not there” and not usable. This will be what happens 10 out of 10 times when freshly plugging it in.

I experimented with the power button at the back of the drive while it was running but not recognized after steps 1-4:

  • Pressing the power button quickly does not do anything.
  • Pressing the power button for ca. 5 seconds will turn off the drive (not spinning, LED off).
  • Then pressing it again quickly will turn it back on. AFTER THAT the drive shows up in disk utility and in finder and is usable.

I also experimented with the power cable:

  • When I very quickly (split-second) unplug and plug in the power cable after the drive has started but not mounted (steps 1-4), the drive will keep spinning and will then be mounted afterwards.

=> So the drive works, it CAN be recognized by my Mac, but it never is recognized when connecting it for the first time. It’s not plug and play and definitively not up to my expectations of how this should work.

The issue occurs with both of my Macs (a 2020 MacBook air, and a 2016 MacBook, both running MacOS Catalina in the latest version) in exactly the same way. Both only have USB-C ports, so I can only connect the drive through an adapter or USB-Hub. I tried 5 different adapters and hubs, it’s the same with all of them. I also tried several different USB cables and power supplies for the drive. The issue is the same with all of them. Also the number of partitions and the file system of the partitions has absolutely no impact on it.
Furthermore, I have two older WD My Book drives (from 2017) which mount flawlessly on the same Macs.

My vendor has replaced the drive twice for me since June because it seemed obvious that it was an issue with the drive, but the 3rd one is just the same, so it seems to be a compatibility issue of some sort.

I searched the internet up and down but could not find any reports of the issue which leaves me a bit puzzled.

  • Does anyone else have this issue?
  • Any suggestions on how to solve it?
  • Could WD do an investigation on it? (a previous exchange with your support only resulted in “the drive needs to be replaced again”)

Hi,

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/12455

Thanks - I know that page. It only contains the steps that got me to narrow down the issue to the above description which is much more specific than any of the guidelines on that page.
What it comes down to is a compatibility issue between the WD Elements and both of my USB-C MacBooks. An older MacBook with USB 2.0 does not have the issue with the same drive. I was hoping for a more technical response, it’s hard to believe that I’m the only one with this problem, as the exact same problem occurs with 3 identical WD Elements drives (2 warranty replacements) and two different Computers (but not with WD drives of other types and those computers, and not with the affected drives and an older computer)

I’m having this problem too. Elements 10TB (I have 2 drives now: 1 is on ‘advance exchange’. MacBook Pro 2020. Catalina. Elements comes with a cable from: USB 3 Micro-B to USB 3 [Type A]. MBPro has only USB-C ports. I’ve tried several adapters. Including Apple®’s™ pigtail, USB hub (USB-C to MBPro, USB2/A port on hub). Opened a case with WD. They suggested different cable: USB 3 Micro-B to USB-C. None in their stock (they would have shipped one to me). I bought one on amazon. No better. I did find an Apple article where lots of people suggest: [they] had a working setup with Mojave, but not working with Catalina. https://discussions.apple.com/thread/250742324 And, I’ve tried the drives on an older MBAir 2012, USB 3[type A] only on High Sierra: no trouble at all. And, I also have a WD MyBook 4TB which works fine any way connect it [via adapters, hub, cable, pigtail] to the MBPro 2020.

Has anyone ‘discovered’ a way around this issue?

Does WD have any diagnostics which run on MacOS? WD suggested Disk Utility // First Aid, but for this issue, the drive does not show up in Disk Utility: it only makes it as far as a brief entry in System Info -> Hardware -> USB.

Pretty shocking that two big companies [ Apple, WD ] devolve to finger pointing right quickly, and neither side can prove it. Rather a black eye for USB standards, in addition to the two vendors.

1 Like

Glad to see I’m not the only one. You are describing the same issues I encountered. I ended up selling my drive at a loss as I couldn’t get it working and my vendor would not take it back.

Hi Frank-M Did you choose a different drive to fit your needs? [ Which one? -) ] tnx /dc

I bought a G-Drive USB-C, which works without any issues (both when directly connected to the mac, as well as via a USB-hub). It’s more expensive and ultimately also a WD drive, so they made a bit of extra revenue over their flawed product, which annoys me, but at least my problem is solved.

Hello guys, I don’t know if you solved the problem or if this is a stupid solution, but since I’m a new McBook user, I found this video guide on how to make McBook recognize the external drives very useful: https://www.youtube.com/watch?v=Ueyr3pbijSA&ab_channel=TheRenderQ
I don’t know, maybe there is another ignorante McBook user like me, out there, who can be saved by that.

Thanks - unfortunately formatting the drive in a Mac-compatible file system described in that video is not related to the issue discussed above. This topic is about Macs not recognizing the drive on a lower level so that it doesn’t even show up in the disk utility.
Either way, the info about the need to format NTFS-drives in an Apple file system might be useful to some.
(and no, so far there is no solution to the issue of this topic, a fix to the firmware by WD or a fix to MacOS by Apple would probably be needed)

I spent 4 hrs driving to/from the closest Apple tech establishment. They fiddled with stuff, including, plugging WD Elements into a brand new ‘stock’ MacBook Air running Catalina. Same trouble. Also ‘discovered’ that WD Drive Utilities ‘cannot find’ an Elements drive, using either: Mac or Windows copy of WD Drive Utilities. Postulated: Elements drive needs a firmware update. But… back on the ‘chat’ with WD support, where they confirm (a) WD Drive Utilities will never talk to an Elements drive, and (b) Elements drives do not have firmware. Really. They said that. I did coax WD Data Lifeguard Diagnostics (Windows only) to have a look at the drive (under a Windows 10 VM under Parallels), and sure enough, the drive has Firmware Number: 1030 I’ve essentially given up on WD, and I’ve bought a G-Drive USB-C (thanks, Frank-M for the recommendation), which should arrive by the end of the week. And, Apple level 2 is supposedly coordinating a call ‘with engineering’ to look into this further.