Wd elements 3T usb 3.0 - not detected by my SAGEMCOM F@st 3864 wifi/modem


I plug my wd elements 3TB usb 3.0 into the usb port of my SAGEMCOM F@st 3864 wifi/modem and it just doesn’t seem to detect it - even though it will detect an older 1 TB usb 2.0 elements drive.

The 3TB drive works fine with a standard pc/linux computer (I think the SAGEMCOM is linux based).

Any suggestions?  Is it possible modifying the software on the drive might help?

My SAGEMCOM F@st 3864 has been customised by my ISP - not a lot of documentation is available, but it appears it will mount a 4TB usb 3.0 drive: https://community.optus.com.au/t5/Broadband-Telephony/Multimedia-on-Sagemcom-F-st-3864-Router/m-p/75079/highlight/true#M12186

Thanks for any help.


Check with the modem manufacturer to see if it supports a 3 TB unit.

Did you tried resetting the modem?

1 Like


I would think if the modem mounts a 4tb drive it will mount a 3tb drive, but I will try emailing the mf with this question.

Yes, I tried both a factory reset and a plain reboot, no joy.

Any other advice - especially, is there any software I might remove from or add to the the drive that might help the modem mount it?


Have you reformatted the drive?


Hi Joe,

No, I haven’t reformatted the drive.