WD Elements 10B8 freezes my computer

I am running a WD Elements 10B8 external drive, 1000 GB. I have never had any problems before, using it.
Maybe it has been slow, but eventually it has worked.

Now it has become VERY slow responding, and I have only used 1/10 of the capacity.

It takes about 10-30 minutes from the time I plug it in, till I can see what is on it. Sometimes it just freezes.

When I run the Data Lifeguard tool, it says that the health on it is good and the Firmware is 1012.

BUT. I get a Read SMART attribute command error and Could not read SMART disk information.

Also I get the message that DLGDiag is not answering.

So what can I do?

Any downloads that would help?

I only got one WD-map on it, that is containing some trial on Smartware Pro free trial.

If you’re having issues with the SMART attribute erroring out, then it’s possible the drive is failing. But you can also try changing the cable. And it’s also possible that you may have some corrupting on the file system.

Thanks for helping. So I can try getting another cable somewhere. What can I do to test if the drive is failing or if there are corrupted files? I tried checking the drive for errors by rightclicking on it and so on. But it just froze trying to check it.
Anything I try using the drive makes it freeze.

I wouldn’t really know. If it’s not the cable, It could be either the case or the drive. Either way, you may need to replace the unit. I would consider calling support, after you get the cable, and see if they can help you sort it.

Ok. I am ordering a new cable today, and really hoping that´s it. My product is too old for support. It was bought in 2015. And i don´t think we have phonesupport in Europe. So fingers crossed now :slight_smile:

Thanks man (Y)

Now i tried with a new cable, it didn´t work.

Does anyone have other suggestions?

I don´t think I will ever buy another WD product again.
This is just not ok. It is about 3 years old, and now I can´t get to all my imprtant data.

Also, I can see a lot of people having the same issue with their WD HD.

Considering the SMART error you reported on your first post then there’s not much else that can be done.

A data recovery specialist my be able to help extract your data since it seems you do not have a backup.

https://support.wdc.com/warranty/datarecovery.aspx?lang=en