WD Element Write speed at <30MBs

I purchased my WD element (2TB) portable HDD on the 4th of October and to sum this up real quick it originally had a write speed of 110MB/s and now it’s averaging anywhere from 30MB/s to 19MB/s. This is really bad considering a hard drive I got years ago pulls 80MB/s.

I also found out the cable that it came with restricted the device to 2.0 and had to change it over with another 3.0 cable I had. I talked to WD and they said they would send me a new one but I never got it.

I’ve been using the hard drive, like some other ones I had which have never had a problem, for recording videos in 1080p 30/fps which means I do need a good write speed to keep the recordings FPS above a constant rate (note i’m not talking about my computers FPS, I’m talking about the frames that the recording software can write which is restricted by write speed)

So yeah, what would be the best way about getting a replacement for my HDD.


Welcome to the WD Community.

Sounds like the unit averaging USB 2.0 speeds, if you already tried using a different USB cable and different connections, make sure that you check that you are using the drive on native USB 3.0 ports.

As you did before, give WD Support another phone call.

Yeah i’ve got another drive running at 3.0 so I pulled that drive out and plugged the WD one.

But I’ve just tried it again and it did actually get to 90MB/s for 2 tests then started varying test to test from 90 to 40-30 and is now stuck on 40-30 again.

yeah I’ll log another ticket with WD.