WD drive utilities diagnostics not running

hi, I’ve had my WD passport ultra for a couple years now. i use it to store my itunes library mostly. recently my device became unplugged without ejecting it through the computer first (though i do this a lot I’m clumsy). i use the passport ultra with my macbook air. it fell off my lap and onto the carpet floor at the airport yesterday… when i tried plugging it back in,
the led light did not blink the same way it usually does. it stayed on, and evidence of the passport did not show up on my dashboard the same way it usually does. I’ve tried numerous times to plug it back in but all it will do is either keep its light on, or flash in longer intervals. also i think its usual humming has been absent, or at least quieter. i entered the WD drive utilities but the three diagnostics options “run drive status check”, “run quick drive test”, and “run complete drive test” ( seen here:http://support.wdc.com/KnowledgeBase/answer.aspx?ID=11430 ) were all greyed over/out and i am unable to click them. if any pro’s know what i could do… I’m really stressed!

Unfortunately, the fall could have affected the mechanical parts of the unit. Particularly so if the unit was disconnected by accident.

Do you have a backup of your data?

I have this problem too. In my case, the hard drive does a clicking noise for about a minute, and then this noise stops. The computer is not recognizing the hard drive, but the WD DRIVE UTILITIES is. Although, none of the diagnostic options are running. The buttons are apparently clickable, but nothing happens.
PLEASE HELP

Same situation happens to me. Have you found a fix to this yet?

Unfortunately no… it seems like there is no way to fix this

Aaaaaaag
I have the same issue - have only used the WD passport twice.
Strange noise and light stays on when connected to MAC. WD Drive Utilities seems to recognise the passport, but MAC doesn’t. Can’t do drive check in diagnosis as the run drive options are grey. MAC not recognising the passport. Help!!!