WD DLNA server non stop indexing

Recently switched my MBL from twonky to WD DLNA & I’m wondering how many days to give it to finish indexing 1.2TB, before I give it up as a bad job & return to Twonky?

At least I’m assuming that’s what it’s doing. I’ve disconnected the Ethernet cable for several hours on end & the disk activity has not ceased. Even though I had issues before (loosing http & share access, which I thought WD DLNA may have helped with), I never had the drive constantly operating like this, so I believe it is the DLNA server causing it.

Any thoughts?


Indexing is a process affected by the total number of files as opposed to the size of those files. This means that a single 1GB file will be processed faster than 1,000 1MB files. How much time has it taken so far?

According to the dashboard I have the following file counts (they look unrealistically high to me):

Music Tracks: 46618
Pictures: 86589
Videos: 2660

I switched to the WD DLNA server in the early hours of 11th May & disabled it about 8pm on 13th (nearly 3 days later) & my drive is now sitting inactive for the first time since the update. Does that sound right, I’m sure Twonky never took anywhere near that time when I ran a rebuild.

BTW have you seen the other thread I recently added to? I’ve added some home hopefully helpful diagnostics to an issue I share with other users ( http://community.wd.com/t5/My-Book-Live/My-Book-Live-2TB-loses-connection/td-p/699310).

Note: I did have to reboot during this period to regain access (due to the lost dashboard & shares issue on the other thread I referred to). I hope this does not force a full index rebuild.

After confirming that the activity stopped after disabling the DLNA service I re-enabled it & sure enough it started again.

that was over two days ago & althiough the disk activity has now appeared to have reduced, it is still frequently enough to prevent the drive ever entering its sleep state.

The WD app on Win8 is also performing rediculously slowly. Upon opening it informs me is is “discovering content” from my drive & adds one or two tiles for new content  at a painfully slow rate until I kill it in desperation.

Next time I open it, it tells me there are a higher number of folders remaining than ther previous time before getting back to that pathetic rate of (apparent) discovery.

This cannot be right, please tell me why I should not regress to Twonky?


Each Media Server is different, and WD’s DLNA Server is not meant to replace or succeed Twonky as they behave differently and offer different features. As such, we recommend the DLNA Media Server providing the best performance for individual needs.

I’ve switched the drive back to using Twonky as the media server, after no time the disk was back to normal (acceptable) activity levels & can now actually go into sleep mode when it in use.
I just wish there was as easy a solution to regress the last firmware update, so I could get the basic NAS functionality back for ore than a few hours after rebooting :frowning:

I have a possible solution to this.

I bought a chromecast and so enabled the DLNA streaming on my MBL.

Previously i had disabled it for the same reasons everyone else complains about. The disk spinning permanately and MBL being very slow for access. I had already disable the mediacrawler program, so it wasn’t that ( update-rc.d -f orion).

Logging in to the MBL through ssh i saw the dlna process was still the culprit, dms_smm at 100%. Previously i had observed this for days/weeks, so it was never going to complete the job it was attempting to do.

With a reason to sort this out i spent some time working out what was happening. Didn’t get to the root cause, although it is probably to do with the number of files on the disk.

But i did come up with a solution.

The DLNA program has a set of configuration files in /usr/local/dlna-access/xml. One of those (excludes.xml) i discovered contains a list of patterns/files/directories that should be ignored for DLNA content (although it could be intermittent on actually obeying this list - possibly because i was runnign things from the command line during debugging).

My MBL has approximately 24,000 files of photos and videos. It also has approximatley 270,000 files from various backups and other things. This is what i found was causing my DLNA scan to never end, or break, not sure which.
Fortunatley for me all those files are under a different directory than the video/photos - but still under the  /DataVolume/shares/Public/ directory - which is where the DLNA scans happen.

So adding ‘backups’ to the list of things in exclude.xml i managed to get the dms_smm process to skip those offending files.

    added  backups to /usr/local/dlna-access/xml/excludes.xml

    restart the DLNA server, either from the web interface or the command line with the /etc/init.d/access script.

    It may take some time to scan your files, but mine completed within a couple of hours with 24,000 files.

There are other files in the xml config directory. The storage_list.xml looks promising, but depending on which version of DLNA server you have it will be overwriten at start time and the script  /usr/local/sbin/listMediaShares.sh will be used to add shares to the storage_list.xml for scanning. I kept it simple and just modded the excludes.xml.

You can count the number of files you have in different directories with:
    cd directory
    find . -type f -ls | wc -l

In the directory /DataVolume/shares/Public/.nflc_data you will find the SQLlite database that the DLNA server is building. Could be that it just got too big with 1/3million files. Anyway with 24,000 files mine is around 40MBytes.

Hope this of use to others that get similar problems.

Excellent detective work :slight_smile:
If I ever get past my services crashing issue (case still with WD, at least they’re talking to me now), I’ve give it a try.

BTW: if you raise a case & get asked to send system log data, be aware that if the extracted zip file exceeds 5mb (which it will if you have many indexed files on the MBL) your message will be dropped by WD with no warning to either yourself, or the recipients - good eh?