WD DL4100 + UART interface

Evening everyone.

I’m sorry for posting here but even more so if this is the wrong place.

I’m having some problems with a DL4100.

The device is no longer posting. Nothing comes up on the display when it turned on. To check to make sure it’s working, I’ve bought a UART to USB adapter to ensure that it’s at least trying to boot the internal hardware via the UART port on the main board.

The hardware itself is OK. The board powers on. Networking on the back of the device is responsive, but when plugged directly in to my router, it doesn’t get a DHCP assigned address.

I’m hoping that someone can post me some instructions on how to flash the mainsboard with the latest firmware revision that I downloaded from WDs support website.

Any help that anyone can give would be amazing.

I’ve tried creating a GPT active boot USB disk with uImage and uRamdisk on but the device, when holding down reset for 4 or 40 seconds still doesn’t try booting from USB… Ugh…

Someone please help as I’m keen to fix this.

The device itself is responsive via power button. Mains board switches on OK but I get a blank LCD screen when trying to startup.

Hi @ajhclarke24,

Please refer to the article How to Access a My Cloud When Connected Directly to a Computer:

The device is partially bricked Keerti which is why I’m having problems trying to get it to boot.

I need instructions on how to flash the device from a tech perspective as the device is in non-recovery mode.


Hi @ajhclarke24,

Please refer to the article Blinking White or Blue Power LED on My Cloud:

If further assistance is needed, please open a case with our support team at the following:

I’m sorry Keerti, but I’m less and less impressed with WDs tech support services.

I’ve had no success with the problem since I bought the device. This problem needs escalating to a level 2 or maybe even a level 3 engineer.

Could you please raise this internally with your team leader and then come back to me with a response?

Many thanks

Kind regards

Hi @ajhclarke24,

I sincerely apologize for the inconvenience.

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for best assistance and troubleshooting:

[quote="ajhclarke24, post:1, topic:276262

I’ve bought a UART to USB adapter to ensure that it’s at least trying to boot the internal hardware via the UART port on the main board.


What are the pin designations on the UART connector and I’m guessing the UART connector is what is pictured?

Your question has been submitted!

Thanks for submitting your question. Use this reference number for follow up: #220310-002283.

Thanks for the response Myron.

I’m using the below picture to try hooking up the device to try and gain access to the linux prompt that the device tries to present over the serial interface.


Pin1 - Ground
Pin2 - Transmit
Pin3 - Receive
Pin4 - Unused (WD specifically say do not use this Pin under any circumstances)

At the moment the device is bricked and I cannot get it to work.

If you can provide any support or assistance with regards to this, it would be greatly appreciated.

Many thanks

Kind regards

Thank you for the reply.

At the moment I’m unable to even diagnose the device because I can’t even get UART access.

This is why I needed some help to try and get it to work.

Any help would be greatly appreciated.

Many thanks.

Like @dswv42 states, if the CPU has killed itself then there is nothing that can be done with that NAS unit. You can get a PR4100 without any drives, transfer the drives and you should be able to access all your data.

Expensive door stop. Nevermind.

Thank you anyway.

If this is the conclusion, I’ll just dispose of it.

Thanks guys.