WD Discovery not installing on Windows 11 and stuck at 18%. Help?

Hello, I have a new computer (I literally set it up yesterday) that runs Windows 11 (I did not update the computer to 11, it came with it). I’ve tried installing the software several times, but it says it fails at 18% installation. I’ve tried restarting my computer and turning my antivirus off. Here are the specs of the computer (I don’t know if it will help):

Windows 11 Home
64 bit

I’m trying to transfer my files from my old school computer onto a new school computer. How do I fix the problem? Thanks.

I’ve looked at this article (WD Discovery Failure to Install on Windows). It says that it won’t install if it is using an ARM based CPU. I looked it up, and it says that it is using an ARM based CPU. There isn’t a solution for this. Can I still install it if I have an ARM based CPU?

Hi @rosemf2000,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Hey, have you finally solved your issue ?

WD Discovery is an application from WD that enables you to: Manage your connected WD devices like My Passport, My Book, drives. Make complex things easy, like securing a drive with a password or managing drive settings.

Just bough a WD Passport 5Tb external drive. My PC is running Windows 11 and the software download wont go beyond 18%. Very disappointed with the purchase.

1 Like

I have the same problem

i hope you will find the soluton…
NCEDCloud login

Well if this thread is several years old, obviously WD has done nothing to resolve a reoccurring issues. It’s March 2024 and I just bought the 5tb Passport, trying to install the digital software and it hangs at 18%.

WD You should be ashamed of yourself in not fixing your software problems after so many reports over so many years!

1 Like

Hi. Just bought the WD my passport and cannot upload the software it gets stuck at 18% as welll. It says try again. I’ve done it 10 times restrtothe ccomouter and running it as administrator. Can you please help