WD Discovery generates problem in Chrome / Firefox and more

Hey,
two months ago I bought My Cloud Home and I have two serious problems:

  1. After installing the WD Discovery program, I have a problem using the Internet browsers - Google Chrome and Firefox. Every action related to a pop-up browser window (eg Save image as …, Add a file …) causes a browser crash (“Google Chrome / Firefox has stopped working”). Interestingly, there is no problem at Opera. I’ve reinstalled Chrome, Firefox, WD Discovery, all software is up to date. In addition, I uninstalled the antivirus program (Comodo). To tell the truth, I tried many combinations, and the problem still exists. The problem disappears only after uninstalling the WD Discovery program (disabling is insufficient). More over, problems occur on every computer in our LAN. We have 10 machines with different operating systems (Windows 8.1 PL, Windows 10 PL).
  2. Another problem concerns the “Share link” option. The shared link is active for some time (sorry, I do not know how long) and unexpectedly I receive the message “An unexpected error occurred, please try again later” (translation from Polish). I have tried many times in different browsers and each link has been “inactive” after some time and I have to generate a new one.

Maybe someone has similar problems and can help me. Thanks for your help in advance.

P.S. In conclusion, I must say that I am very disappointed with this device. I had hope that a few functions of this Cloud will make my life easier, but I have spent many hours solving many problems and now I have to use this device only as an ordinary external disk in my network environment.

/ Adam

Hello,opiat

You should try contacting WD’s Technical Support about this for live assistance and troubleshooting

To Contact WD for Technical Support

The link below will allow you to call support