WD Discovery Fails to Update

I have a My Passport 2.5" Portable USB 3.0 1TB External Hard Drive
P/N WDBYNN0010BBL - OB
Purchased 26/4/2018

WD Discovery 1.3.329 was installed on my initial installation.
I receive notifications that 3.0.250 is available for update. When I update it, it appears to update but at the end it notifies me that the update has failed (indeed, I still have 1.2.329). I tried downloading and installing the latest version and that failed also.

Hi HolyHarp,

Please check your PM.

Thanks Brandon. I disabled my Avira antivirus, quit Malwarebytes, and disabled my firewall. I ran the installation package. When it told me there was an update available (2.1.332), I clicked on “update.” It ran for awhile and then told me, “WD Discovery update failed.” I’m running Win7 completely updated.

You should completely uninstall WD Discovery from PC then install updated version of WD Discovery (Version: 3.0.376) from WD support site.

I uninstalled the program and deleted as many of the directories and files in the instructions that I could find and that the computer would allow me to delete. I made sure my antivirus, malwarebytes and firewall were off.
It worked. Thank you!

Same here, installation failed, both plug in and app. I’m running Mojave, both my son and wife who’s running the same OS are able to install. I’ve deleted everything including everything I can find in the Library, still getting the same message, installation failed