WD Discovery does not work with MacOS Ventura

Since upgrading to Ventura, WD Discovery no longer functions. I can’t log in. I have uninstalled and reinstalled but get the error message to change system preferences. Ventura no longer uses system preferences but systems setting and it’s nothing like the example.

I have reported to support but they don’t seem to understand the problem. Has anyone else had this problem and how do I solve it?

2 Likes

I also upgraded a MacBook Pro 2017 to MacOS Ventura 13.0 and the sync file option no longer is available. I also have contacted the support center and they have no idea what to do. The support center told me to contact Apple. Does anyone know what to do?

1 Like

Greetings,

We have reached out to you via direct message, so we request you kindly check and reply to your DMs so that we can assist you further.

I have the same problem. Link provided in the sign in response does not match up to the new System Preferences in Ventura. The update is junk! Has a solution been found???

Nevermind. I found the extension in System Preferences. Got it to work. Did a search for “Extensions” and checked the various listings. Hidden in small print was the WD Discovery extension setting to “Allow”. I WOULD HAVE EXPECTED BETTER INSTRUCTIONS FROM WESTERN DIGITAL.

Same issue for me. As far as I could, I ticked the extensions and allowances, rebooted the system….now the device is visible on the Finder, but I cannot access my files. WDdiscovery asks for additional extensions…looking forward to the update. what are WD doing? (No answer to the case I submitted yesterday).
Why isn’t there any possibility to connect directly to the nas without having to identify through this messy software, which disconnects all the time (in normal times), and hinders any kind of synchronisation?

I do t think they realize there is an issue. I keep getting the same set of “fixes” which do not address the problem.

And you’re correct why is WD discovery even necessary.

macOS 13 Ventura has changed the query structure in Finder search which caused a compatibility issue with SMB and AFP protocols.

Other NAS brands are having the same problems and have not updated. Good luck keeping up with changes in macOS.

Found a solution:

In the system settings, go to the Privacy & Security tab and scroll down past all the options to the box that says: “Your current security settings prevent the installation of system extensions.”
Click on “Enable system extensions”.
It will ask for Touch ID / Password and then tell you to shut down your mac. Do that.
To turn your mac back on, hold down the power button until it says “Loading up start up options”, then click continue under the Options icon on the right side. Go into the Disk Utility mode and then in the menu bar under Utilities select “Startup Security Utility”. Under Security Policy, choose “Reduced Security” and check the option: “Allow user management of kernel extensions from identified developers”.
Restart your computer and return to the Privacy & Security tab in your settings. You should now be able to enable the WD extensions and login to your account.

Thank you so much, that worked. It’s ashame that WD did not tell me this weeks ago.

John

Thank you so much. It works. I spent hours applying their last instructions…for nothing.

To be precise, they had sent me something close to that, apart the fact it was accurate for Monterrey (hard to find the equivalent in Ventura, especially in the startup menu).

Nothing they sent me cane even close. Thanks again