WD Dashboard Hangs During Install


Tried installing WD Dashboard on a Windows 10 system tonight and it stalls half way through. Odd thing is that the icon appears on the desktop as well as in the start menu - and launches … ?!

Any suggestion on how to get the install to complete?


Hi @Whyrd,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:https://support-en.wd.com/app/ask

Not yet - doing that next, thanks!

Tried inputting a support request back in February, but none of the pick list options seemed correct. Tried the install again tonight - and it worked! Don’t know what they changed but Dashboard is up and running!

One possible solution you could try is to uninstall the partially installed software from your system, restart your computer, and then attempt to reinstall it again.

Alternatively, you could try downloading the installation file again from the Western Digital website like https://ppprecipients.com/ to ensure that you have a complete and up-to-date version of the software. It may also be worth checking if your system meets the minimum system requirements for the software, as this could also cause issues during installation.