WD Cloud Software upgrade from to

When I open the My Cloud software, it tells me there is an upgrade available to v.   I see my present

version is  I have continued with downloading the new upgrade, running the install, and then when I

open My Cloud, it again shows my version as and asks if I want to upgrade.  I have tried to upgrade

three times, each time installing the software.  Same issue.  Anyone else having this issue? Any suggestions

how to make the upgrade stick?

If the software is working fine you can leave it as is.

Otherwise, you can uninstall the previous and download the latest version from our website.


I enounter same problem. When trying to uninstall I receive error 2318.

Did you managed to have it fixed?

same error… and i can’t disinstall… i try everything… but it gives me the error 2318…

same thing if i try to update leaving the older version on pc… 

any solution??? 


I have exact same situation.  Each time I open the WD My Cloud application it tells me my existing version is and offers to download version which I accept.  However the new version will not install and I cannot remove the old version.  I also get same error when attempting to remove old version which is error 2318.  What do I need to do to get the old version off my machine, so I can then install the latest version?

hi… i have found a solution… but i don’t remember all the steps… probably you only need to turn off the power of the wd unit for 30 seconds and restart… and it goes right… i’m so sorry but i don’t remember right steps…