WD Blue failed since I force shutdown my computer

Hello, I was using a WD Blue 2TB disk with 5400rpm (which I believe it’s a rebranded WD Green) WD20EZRZ as a D drive to store games and data. After I attempted a force shutdown on my computer by holding the power button for few seconds, the drive failed and started making a ticking noise constantly which was not present before, and I couldn’t boot up the pc anymore. The pc starts up fine if I unplug the SATA cable for this drive.
Sometimes out of like 50 attempts, it will recognize the drive and boot up, and I do have an access to the data stored, but only for about a minute and it starts making that constant ticking noise again and completely freezes the pc. What could be the problem? I thought some firmware related to the Intelipark feature got corrupted, therefore making the head park every 8 seconds, so I tried disabling the Intelipark via WDIDLE3, but no avail. First of all, it will not recognize the drive, and after several attempts, it will sometimes recognize the drive, but gives the error “VSC Enable Offline”.

Interesting thing is that I tried timing the gap between the ticking noise, and it is exactly around 8 seconds, which is the timing for InteliPark.

I also uploaded a video on Youtube for reference. (You might have to put the volume at 100%)

I only used this drive for about 3 years in a well-fixed environment with vibration damping as well. What could be some cause of this problem? Are there really no ways to recover the data from the hard drive except taking it to the professional service place?

Hello,

We would recommend you perform a diagnostic test on the drive to determine its optimal health by following the KBA article: http://support-en.wd.com/app/answers/detail/a_id/6226/