WD Black2 Partition software fails during installation

Firstly, I love the concept of combined SSD&HDD for my laptop - this drive sounded perfect as I could not decide between a large capacity HDD and a dearer but smaller capacity SSD.

I installed the Black2 hardware in my laptop with no problems.

I did a fresh install of Windows 7 onto the SSD partition - no problems.

I downloaded the Partition Utility from the website pointed to with the USB key, but when I tried to install it (using Admin rights) it failed during “Checking Operation feasibility” and a pop message apperard saying “WD Black2 Dual Drive Installation Software has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available”.

I have tried several more times, after various Windows updates, but still get the same problem.

Any ideas on how to sort this will be gratefully received!

1 Like

Hi humpf, if you are trying to install the software from the USB memory, try to copy the instalation file to the PC and install it from there.

Thanks for the reply ichigo, but apologies for my clunky phraseology.
What I meant to say was after win 7 was safely installed and working on the ssd, I inserted the supplied USB key which pointed me to the WD website, i then downloaded the partition utility to the documents directory on my laptop.
I extracted the file and tried to install the partition software from my c: drive by right clicking and using admin privs, but during this phase the install failed as described above.

Does your HDD partition show up on your desktop?  If not, have you tried rebooting your laptop?

Did you already have the Partition software already installed?

If you do, it should only give you 2 options, Reinstall or Remove.  Try using the remove option, then try reinstalling the software.

Sorry for taking a while to reply - family visitation stopped play.

No, the HDD partition is still not visible even after reboot.

The Partition software only give me the install option for many goes but one time I tried it and I got the same error message but it happened a lot later - the progress bar had nearly reached the 100%.

The next time I tried to run it I was given the two options you listed - I tried both but every time I got the original error.

I am beginning to wonder if the laptop is too old for this sophisticated kit? I bought it in 2006 and it was one of the first Intel Core Duo T2300 machines available.

Have you check to see if your SATA driver is up to date?

Open the Control Panel, select Device Manager, then in the Device Manager expand “IDE ATA/ATPI controllers”, right click on your controller and select Properties.  In the new widow click on the “Diver” tab and select “Update Driver”.  Then select “Search automatically….”.

If it says that your driver is up to date or you are already using the best driver, post what SATA controller you are using and the version number.

If you have an older driver it may or may not be what is causing the problem, but it will be the easiest thing to start with.

Hi Tinwarble, Thanks for the suggestion.

I tried updating the driver but it said I already had the latest ones installed.

The device is listed as:

Intel® 82801GBM/GHM (ICH7-M Family) Serial ATA Storage Controller - 27C4

What driver version number does it state?

Also, you can try Intel’s Driver Update Utility here: http://www.intel.com/p/en_US/support/detect?iid=dc_iduu

since Windows does not always detect whether there is an update or not.

 

Something else.

Go to Control Panel / Administrative Tools / Computer Management, then select Disk Management.  You should see something like this.

Where mind shows “(D: )”, you may see Unallocated space.  If you don’t see anything other than “(C: )” then we’ll have to check something else.  If you can, post a pic of what your Drive Management shows.

hi i have the same problem as humph and i tried a couple of things i tried other programs and trying to install the firmware update(i was not able to do that) the hdd portion does not show up under disk management and when i try to run the install it just stops working have you found a solution please help me i really really need that 1tb

Not much help I know but I have the same isuue.

Following the software initiated reboot I get

“An error has accurred while installing WD Black2 Dual Drive”

“Unable to detect WD Black2 Dual Drive”

“Completion code: 0”

Anyone got any ideas?