WD_Black SN850 not detected by BIOS on bootup from power-off

Please repair sn850. No detect bios

2 Likes

did you manage to fix this issue? (edit: I just noticed this is quite old)

well anyway I bought 2x WD SN850’s a few days ago and had the same issue M2_1 (bootable drive) would only be found from a reboot, and not cold boot, but M2_2 (storage) found every time from cold boot.

A few messages later with MSI (I have the MPG x570 GAMING PLUS) they told me there is a known issue with the WD SN850 and they have released a customized bios version to fix it. Why its not just added to ‘the latest’ is beyond me! (the custom one is a downgrade from the latest) but mine is now FOUND from cold boot every time.

I now have 2 SN80’s working together nicely xD

No, got a different SSD and it’s fixed.

1 Like

Just bought a 2TB SN850X drive and attempted to install with MSI X570 GAMING PLUS. Would not work in M2_1 (PCI 4) but it would work in M2_2 slot (allegedly max PCI 3). Both motherboard and SSD had stock firmware, I was able to update firmware by placing it in the M2_2 slot. I updated firmware on the motherboard and drive but the drive would still not work in M2_1, I am now forced to run this in the M2_2 slot.

Firmware versions:
SN850X Drive bios versions: 620281WD → 620311WD (Latest at time of posting)
Motherboard bios versions: A10 → AL0 (Latest at time of posting)

Interestingly the WD dashboard utility claims the interface speed of M2_2 is Gen4.

I did a quick benchmark through CrystalMark 7 and was able to get 6300 MB/s Read in the SEQ1m Q8T1 benchmark, So performance doesn’t seem to be bad - I was worried this would be capped lower.

1 Like

Yep problem exists for 2 years now and no fix in sight!
As I said before, ■■■■ WD support! I learned my lesson and I will not buy another WD product!
This support is insane bad!!!

Greetings,

We have reached out to you via direct message, so we request you kindly check and reply to your DMs so that we can assist you further.

This is insane. I’ve had mine since 5/1/22. Strix z690i 12th gen i7. Did the usual 5 hours of thinking I could fix it before finding this thread. Please create a recall for this product WD.

Exact same thing here, bought on Black Friday because it was rated to be the fastest NVMe, pumped, installed everything perfectly well, PC restarts, NO SSD, WHERE’S THE SSD HAHAHA, GONE, BIOS can’t even see it, after 5 restarts, voila, your boy is back, this happens every time.
After trying to update the firmware and reseat it, I Google it and guess what, massive thread full of people with the exact same issue. Welp, I guess that’s a refunder haha, I’m never getting anything from WD again, wasted my time driving to the place to buy the SSD, wasted my opportunity to get a good deal on the black friday, gonna have to buy an enclosure to connect the NVMe and write 0s over it before refunding, all that because a company can’t QA its products against a motherboard vendor, or just has poor firmware programmers/providers. Samsung or Crucial it is boys, there’s no other option unfortunately!

Specs:
MSI B450 Tomahawk latest BIOS (1.I0 AGESA 1.2.0.7)
WD BLACK SN850X 2TB Latest Firmware 620311WD

Send it back as soon as possible and get refund!!!
WD don’t give a **** to fix this issue

It’s already comfy in its box, ready for a full refund ksks. Really pisses me off how much time and opportunity I wasted with this though, I just can’t risk buying anything from Western Digital again. We need a law where we get paid for the time we spent trying to fix a problem known by the manufacturer that did nothing.

I can confirm that I am also having this problem over 2 years later! I have an ASUS board. I wish I would have known before I shelled out money to buy 3 of these about a month ago. The other 2 work fine.

First boot I can see the files in file explorer but don’t have access and get messages suggesting it doesn’t exist. WD-Dashboard will show the drive but when I do anything that accesses it, it will disappear. Once I reboot it works fine.

x3 WS_Black SN850 2TB (I bought directly from Western Digital) (firmware up to date)
Asus ProArt Z690-Creator Wifi.

do you have any info about what BIOS revision it was?

No Fix after 2 Years???

They don’t care about the problem anymore! WD850 is near EOL.

Make them learn the hard way! Return or buy other brands!
After this WD is history for me.

I write the support until I get a new one! 2 Yers is tooooooo much!!!
To much is to much!

Good Luck with their support center in India or somewhere.
Sometimes it seems they don’t even understand what’s the problem.

As I said, I have learned my lesson. I buy a lot of hardware and will not buy WD again nor will I recommend it,

Their support is joke! If a company can not fix it with firmware, they have to recall or refund it.
But it is a waste of time here; buy other brands and forget WD

please, bios no detect sn850x

SN770 1TB on ASRock B660 Pro RS, i7-13700

It was a new system, put it together about a month ago, and everything was fine, no problems whatsoever, then few days back this “not-detected” issue started happening, when the PC is left turned off for a while, can be overnight, or few hours, on 1st turn on the BIOS will not see the SN770 drive at all, soft restart doesn’t help, turning off for few seconds and back on so far helped every time.

Just installed Dashboard to check the firmware, and it has the latest one already (731100WD), no update available, ASRock B660 also has the latest 12.03 firmware since I bought it.

All tests, smart info, etc is green, good, fine with the SN770, just that it occasionally won’t be detected at a cold power up.

SN770 is installed in the M2_1 slot, like the mb manual suggests, and I just checked the QVL, the 2TB version is listed as compatible, so I guess the 1TB should also be fine, and it was, for a while…

CrystalDiskInfo sais it has 87 power on counts and 355 hours total so far. Transfer mode PCIe 4.0 x4

small update:
I disabled fast boot in Windows 4-5 days ago, and ever since I haven’t had any non-detection events at all, no other changes have been done to the pc

Seems to be no rhyme or reason to this.
I’ve experienced this issue with two different SN750(original non-SE). One in an AMD B550 motherboard. The other in an Intel B365 motherboard.

Today I ran into the issue with an SN550 using an nvme PCIE adapter on an Z97 motherboard. It happened after booting into various linux distributions on USB flash drives so I don’t think Windows has anything to do with the issue.

Really at a lost here. But I will not be buying anymore WD SSDs until I hear of this issue at least being acknowledged and investigated. There’s plenty of other worthy brands that aren’t having this issue.