WD_Black SN850 not detected by BIOS on bootup from power-off

im having the exact same issue. MSI X470 Board. NVME_1 is Samsung 970 Evo. NVME_2 is the SN850.

50% of the time the drive doesn’t appear unless i reboot. So frustrating!

There is almost 10 thousand views on this thread, It’s been almost a year since the first post too and people are still having this issue… what is being done about this? Western Digital? Hello?

I have two SN850 both have the same problem on both computers. x570 boards.

Lovely SSDs… Installed a SN850 w/ heatsink in the M.2_1 slot to handle large media files and swapped my windows SSD to the M.2_2 slot. Was working fine for two months and suddenly crapped itself today. Computer randomly crashed and was stuck on the infinite boot loop. Spent three hours troubleshooting. Stripped PC, updated BIOS, reseated everything, etc, etc. Removed the SN850 from the M.2_1 slot and kept the windows SSD in the M.2_2 and voila, my computer works fine. Now, I need to recover my files from the SN850…

still no update to this. shocking.

ill be puttings this NVME in my PS5 and buying something that works for PC

1 Like

Ive tried contacting support. No response. I want these drives to work, im stuck with them and 400 less in my pocket due to certain circumstances.

1 Like

Made an account just to say I am having the same issue. I have two SN850s installed in my PC, a 1 TB unit and 500 GB unit. Motherboard is an Asus ROG Strix B550-I with an AMD Ryzen 9 5900X. The 1 TB is installed in the M2_1 slot and the 500 GB is installed in the M2_2 slot. The 500 GB unit contains the OS. Starting my PC from shutdown causes it to boot into the BIOS first since the SSD doesn’t get recognized. It works just fine after the restart. The 1 TB has no issues at all. Motherboard is on the latest BIOS and both SSDs have also been updated to the latest firmware.

Confused and frustrated to say the least.

2 Likes

MPG X570 GAMING PLUS with SN850 i have exactly the same problem… please guys fix it the problem

1 Like

I have the same M.2 and a MSI Wifi Edge X570

Cold boot dont Work! Only Reset Botton Works to Boot the System! Please Fix in New Firmware! I have Pay for a full working M.2 and not for a half working SSD!!!

2 Likes

fix when WD?

I recently purchased a WD Black SN850 during black Friday sale and had the same issues with drive not being detected on boot. I managed find a workaround by using a PCIe4 to M.2 Adapter. Have put my findings below.

My Computer Specification:

MSI Gaming Edge WiFi running firmware MS-7C37 v1.G3
AMD Ryzen 5 3600 CPU
500GB WD_BLACK SN850 NVMe SSD model WDS500G1X0E-00AFY0 running firmware version 613200WD

Fault Symptoms:

M.2 drive installed into M.2 Slot 1 (M2_1) has issues with detection, had to reboot twice every time machine is started for M.2 drive to be detected.

M.2 drive installed into M.2 Slot 2 (M2_2) has no issues with detection but M.2 drive only runs at PCIe 3 speeds

Workaround:

Purchased and installed PCIe4 to M.2 Adapter (£15 from Amazon UK) into PCIe slot 3 - PCI_E3. Machine now boots every time without issue. CrystalDiskMark Speed of drive was as follows:

M2_1 Slot - Seq Q32T1 Read = 6976MB/s
PCIe Slot 3 via M.2 Adapter - Seq Q32T1 Read = 5905MB/s

PCIe m.2 adapter with slot read speed is about 85% speed of slot M2_1

M2_1 Slot - Seq Q32T1 Write = 4178MB/s
PCIe Slot 3 via M.2 Adapter - Seq Q32T1 Write = 4080MS/s

PCIe m.2 adapter with slot write speed is 97.6% speed of slot M2_1

Conclusion:
Not sure if the issue is caused because the drive is linked directly to the CPU, the firmware is faulty or there is an issue with the motherboard firmware. MSI manual it says M.2 slot M2_1 is directly linked to the CPU, M.2 Slot M2_2 and PCIe slot PCI_E3 are linked to the CPU via the chipset. WD should really be working with AMD / Motherboard vendors to get this issue sorted out. Hope this helps.

I have the exact same issue SN850 1TB never found on cold boot, always works 2nd time or on restarts.

Motherboard is Asus TUF Gaming B550M-Plus

And is updated to latest firmware

Great support from WD, no answers, no fixes for a year! Never ever gonna purchase their products because of that.
Obviously there is an issue with 850 controller that could only be fixed with firmware update

Having since updated my BIOS, I have not had this issue in 4 months.
It might be worth updating your BIOS - AMD motherboard in this instance (take note of BIOS settings beforehand) and look at the release notes of the BIOS update to see if the changes may be helpful for this (NVMe/PCIe). I don’t know where the fault is, but seems to have been fixed by a BIOS update. I wish WD were more communicative on this issue. It might be a good idea to contact your motherboard manufacturer about this issue, I have found them very helpful and responsive (ASrock in my case).

Hello, is there some news ?

At the beginning, same probleme here - SN 850 1TO - MSi X570 gaming edge wifi. Need to start for windows. Then I’ve downloaded WD DAshboard and upgraded the firmware (614900WD).

Now it won’t start anymore. The SN 850 place on M2_1 wasn’t detectec in the bios.

Then I change the SN850 to M2_2 (pcie 3.0) and it’s works fine …
To reassure myself, i just bought a be quiet heatsink cause it looks like, it will stay for a long time on the M2_2 slot …

1 Like

I am having a similar issue on my MSI B550-A Pro / Zen3 CPU, my brand new SN850 500GB is being detected just fine in the M.2_1 slot, however, it is running as PCIe 3.0.

A new BIOS with AGESA 1.2.0.5 was release just a few days ago, the SN850 firmware is up to date (614900WD).

I already disassembled my computer, cleaned all slots, reassembled it with an minimal config (no other drives but the SN850, no other USB devices but mouse and keyboard), but my system simply refuses to connect the SSD as Gen4.

After reading this thread, I am still not sure if I should RMA my motherboard or the SN850, or if I should just wait for better times…

Anyone found any workarounds apart from updating BIOS because mine is the latest version atm.

I have contact with the WD Support, this is a Known Bug, works on the Problem, but ALL have this Problem Contact the Support and the Link to this Post, i Hope this make pressure to the the Dev Team! More of one Year, ist a No Go!!!

You really think they will fix it after one year? :joy: :joy: :joy: :joy: :joy: Good luck!
I don’t believe in this anymore and I don’t waste my time anymore withe this ■■■■ support.

My solution is: I will never buy a WD Product again, that is the only way you can hurt WD and make them think about their support and company policy,

There are enough good and fast SSD’s from other companies out there!

1 Like

This its a TOP SSD and when more user make pressure its the probability bigger!

Good luck! I’ve been waiting since 20th December 2020.

  1. Their 1st level support is not worth the word support - guess their center is somwhere in India
  2. Some computer magazines like Computerbase wrote about the problem - still no solution

If you can return the SSD - do it, it’s not worth waiting for a fix

I won’t buy a WD SSD again

2 Likes