WD_BLACK SN750 NVMe stops working until reboot

Hi,

I’m having an issue where my 1TB WD_BLACK SN750 NVMe stops working after a while until I reboot Windows. I’ve updated the chipset driver and BIOS for my motherboard, and have tested the drive in both of the M.2 slots on my MB with similar results.

When this happens, Windows event viewer shows stornvme Event 11 with the error info: The driver detected a controller error on \Device\RaidPort0. I am not using RAID with the drive.

Any ideas?

What kind of brand and type of computer?

Desktop
MB: MSI Z490 Gaming Edge Wi-Fi
CPU: Intel Core i5-i10600K

Is RAID mode in BIOS disabled and ACHI mode enabled?

Yes, it’s in ACHI mode

WD SSD’s don’t have their own NVMe driver, but they are using the standard Windows 10 NVMe driver [stornvme.sys]
It’s wellknown that this driver can cause many problems during installation of the SSD as well as Windows 10 itself.

The only thing that worked fine for me was a completely clean installation of Windows 10 on the system.
A decision that you don’t make easy.
Believe me, I have really tried all the solutions that can be found on the internet, but for me nothing helped.
After this debacle I only use Samsung SSDs. The advantage of this is that the Samsung Magician software can be installed without problems and that the SSDs use Samsung’s own NVMe driver.

Tried a clean install, reformatted the drive etc. and still having issues. Time to RMA I guess, probably going to get a Samsung as well.

pe 13. marrask. 2020 klo 19.15 Cosara via WD Community (wd@discoursemail.com) kirjoitti:

Not working?
Did you do a clean install of Windows 10 from an usb-stick by using the media creation tool? With that you will get all the newest software and drivers.

If you want to try more, see this: Fix: Reset to device, \Device\RaidPort0, was issued
For me, nothing worked, but you never know if you don’t try.

Yes, did a clean Windows 10 install from a USB, got constant windows crashes after a while. Reformatted and partitioned the drive etc., nothing helps. Starting to think it’s just a faulty drive, going for a replacement today.

To be sure it’s not a faulty motherboard:

  1. Try this SSD in another computer. If it’s working, the problem is (probably) caused by the motherboard.
  2. Try another SSD in this computer. If it’s not working, the problem is (probably) caused by the SSD.

Personally I find the Microsoft standard stornvme-sys driver pure c.r.a.p. or just to sensitive for many configurations.

I’m also having the same issues, but if I found any solution then I’ll let you know (targetpayandbenefits)

I ended up getting a refund and got a Samsung 970 instead, works like a charm.