WD Backup does't display my backup

I made a backup a few days ago using WD Backup on my new My Passeport Ultra 1TB.
My laptop then died so I bought a new one… Now I want to restore my backup - seems logical.

I reinstalled WD Backup, plugged in the drive but then the “Restore” section is blank; it wants me to create a new backup plan. I tried to create a new one on the same folder that was backed up, it it’s still not recognizing the original backup.

I can’t believe the WD Backup cannot just Restore the saved backup, let alone not even see it!
common WD, you gotta make this easy for us, please.


Are you able to access the drive manually? If yes, are you able to see the backup folder on the drive?

Yes, i see the directory and some hashed sub directory and then other content in there…

it looks like the files are in there… but the timestamps are all of the backup date…

did I miss the intent of the backup tool? seems like I should have just copied/pasted the backed up files in the first place :confused:


Having same issue. Got a new PC and attached drive. Can view previous back-up from prior computer by directly accessing the drive. However the drive doesn’t acknowledge the prior PC back-up in restore mode. Established a backup schedule for new PC and can see path to old back-up but files are not viewable in restore mode. Invested 4+ hours and gave up. Plan to copy data from old device on flash drives and move them to new computer manually.