WD Backup completes but no files evident

System:

  • WD Backup (updated after uninstall/reinstall 5/2018)
  • My Passport ultra (3TB) with firmware update as of 5/2018.
  • Windows 10 (updates current to 5/2018)
  • Security = Malwarebytes Premium (current updates) and Windows Defender (current updates).

History: Backups were working fine until 3/3/2018. After that point, no new backups are evident, either as ‘latest backup date’ in ‘settings’ view of WD Backup, nor in list of available backups for Restore function of WD backup. App indicated the scheduled backups were ‘missed’.
To resolve, completely uninstalled all WD software and reinstalled, including firmware update and latest WD apps updates. Deleted and recreated Backup Plan, ensuring target files were included. My Passport Ultra as destination for the files.

Current Symptoms
Both via “Backup Now” and also via schedule per Backup Plan, the app goes through the motions of creating a backup. Takes just over an hour, during which WD Backup app indicates “Preparing Backup”, but does not show any %Complete progress indication of any sort.
Notifications are recorded in the WD App Manager app (in Sys Tray) for time backup started and time backup completed. Notification says the backup was successful.
However, WD Backup app continues to show “None” for date of last backup.
Similarly, Restore function of WD Backup app > Select Files To restore > View Files From shows no files since the 3/3/18 backup.
Subsequently, browsing My Passport Ultra drive, using Windows Explorer, does not reveal any data associated with backups post-3/3/18.

Suggestions for how to resolve, or must I ditch WD Backup and use another backup software, such as the program native to Windows?

Hi ITPA,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

Has this problem been solved? I am having the exact same problem. It’s been going on since May 2018, but I didn’t notice it until now because it kept saying that the backup was successful. I followed the instructions to delete and reinstall the app, but that didn’t help.

Can anyone comment on this? I worked with support, but their solution did not fix the problem. I will be calling them again this week but I was wondering if anyone has made any progress with this.