WD 4TB drive showing as 1.6TB Drive

Recently purchased a WD “Black” 4TB harddrive as a secondary drive in my new Dell XPS 8930 (i7-8700, 8 core processor, ), 32GB DDR4 RAM, 32GB Intel Optane memory. In other words, state of the art PC…right?, wrong! BIOS must be missing something, even though a BIOS update was flashed two days ago.

This 1 month old system and 3 other systems (one of which was also a new DELL) would not see the entire 4TB drive. I could initialize as a GPT drive (instead of MBR) using Acronis WD Tool or Win 10 Disk Management, but it would still not show the entire 4TB in order to format. Would only format to 1.6TB.

Took the drive back to the computer store from whence I bought it and they experienced the same trouble as I did. Then they placed the harddrive in a newer troubleshooting system and found the entire 4TB drive in order to format it for me. Problem solved in 20 minutes. Their technician believes the system BIOS is the culprit.

Summary: Dell should look into this BIOS issue as a possibility. WD should consider pre-formatting 4TB internal harddrives since these have to be in GPT to be seen completely. WD preformats all of their “desktop” (ie USB connected) large harddrives, why not the internals? If the 4TB is going to be used as the OS drive, then perhaps the OS partition can be created in MBR (required) with another partition in GPT??? Don’t know if that’s possible.

No need to respond to this topic.