WD 2go unknown error connecting Dropbox on WP8

I am able to connect Dropbox OK as an extra device on my iPad and Android devices, but my Lumia 1020 is no longer (?) connecting to Dropbox, The error message shows Connecting to Device, WD 2go, Unkown error, OK. 

Another app ‘cloud6 for Dropbox’ does connect OK on the 1020…

I have tried de/re-installing WD 2go. I have also tried de-activating Dropbox from WD MyCloud, but none of these actions help.

I would be happy to try an older version than 2.2.1 or a Beta version.

The app is connecting OK to MyCloud and Onedrive by the way.

Edit: The same error occurs on the Lumia 520 too…


What firmware are you running on the device?

Have you tried resetting the devices?

Hei, and thanks for your reply

The firmware revision of both devices is the latest available (Black) 3051.40000.1345.1002

If you mean have I done a hard reset of both devices, the answer is no, and I would hate to lose all my data on these phones…

I have submitted a support request - 

New Case Created - Ref # : [[Deleted]]

and expect to hear from them in the near future. Hopefully they will have a beta version I can try :slight_smile:


Just to bring this post up to date.

I have exchanged several emails with Support, but have only been advised that my router needs to be set to uPnP.

They don’t seem to be reading the fact that this problem ONLY occurs on the Windows Phone 8/8.1 Preview running WD 2go.

All of my Android phones/tablets, and my iPad work perfectly, ie it has nothing to do with uPnP, which Apple Airport Extreme routers don’t support.

I am only using the local LAN, and have no intention of accessing My Cloud/Dropbox remotely (even if it does work slowly).

Not too happy with Support at this point in time, though I am happy with My Cloud, but for this feature not working on Windows Phone 8/8.1.

I assumed WD would be interested in this feature fail.