WD 2Go App iPad & iPhone


I am hoping someone may be able to help me . . . .

I have a My Book Live Duo which is working really well with one exception, I am unable to access the drive via the WD 2Go app on either my iPad2 or iPhone4 either from my home network or external to it.

I am able to access the drive via the WD Photo app on both devices (which works really well) and also via WD2go.com. I am also able to use “File Browser” app by Stratospherix to access the NAS again from both devices.

Both devices appear to be setup correctly in Remote Access and the app appears to find the MBLD correctly however when the app loads it does not display any shares.

I am running a Virgin Superhub router and have adjusted various settings - restored to factory defaults etc I have also tried powering off / on the MBLD and used the Rebuild option under Remote settings. Have also tried changing from Automatic to Manual settings.

On the ipad / iphone I have deleted and re-installed the app several times but to no avail.

Any help that could be offered would be very much appreciated.

Many thanks.

Also check if you have the latest my book firmware update installed. 


Thanks for the reply. Yes I believe I have the latest version installed already - the MBLD tells me that the Firmware is up to date.

I assume the devices are correctly “paired?”

If so, the device name will be listed in SETTINGS / REMOTE ACCESS / MOBILE ACCESS.

if your device is listed, the USER that is assigned to the device will be listed next to the app name (in the middle) and it should be listed as “connected.”

Yes the devices have connected next to them and assigned currently to the Admin user - so they appeared to be paired ok.

Pleased to say I finally got this sorted by performing a Factory Default without reformatting as outlined in this thread