WD 2 TB HDD not accessible

so i bought this 2 tb external hdd today and first thing i downloaded the wd discovery app, i could see the space and i tried to copy photos and it worked, i tried to set up a password and i successfully did from the app, but once i did, photos stopped transferring, i disconnected the drive and connected back again, but it shows up as a cd rom without space and now i get A:/ is not accessible, the request cannot be perfomed because of an I/O device error, i tried disk management where the drive shows up without any space, disabled the VC but didn’t work, unistalled the drivers didn’t work and i’m lost how to even get this thing to work.

An I/O device error is an indicator of a failing hard drive or USB media. Failure could be logical or mechanical such as file system corruption or stuck actuator arm. Additionally, a faulty wire, disk errors, severe drive corruption, corrupt driver, and hardware damage could also lead to the hard drive device I/O error.

To fix the I/O error, you can try the below methods:

  1. Check if the drive is connected properly
  2. Reset the BIOS
  3. Re-install the drive’s drivers
  4. Try connecting to a different port/PC
  5. Use data recovery software to avoid further damage

An I/O device error may lead to a severe data loss situation, so to avoid such situation its advised to recover data from such drive before fixing the issue. To recover data from such drive you may need help of trustworthy data recovery tool such as Stellar Data Recovery software.

Hope this will help!

如何“重置BIOS”???我的10T Mybook 也有这样的问题,快疯了!