WD 1TB Passport drive error: 0x80004005 when reading back data from it

I’ve backed-up a lot of data onto a WD 1TB Passport drive without any problems. Now I am trying to restore the data back to my computer and I keep getting error: 0x80004005 on several (not all) files.

I’ve tried restoring to 2 separate computers, both running Windows 7 SP1 and I’ve tried both USB 2.0 and USB 3.0. All the combinations I have tried result in the same files erroring with error: 0x80004005.

Can anyone help? I really need this data restored back safely.


Are you trying to restore the files to the original location or to an specific folder?

I’m actually trying to transfer files from my Desktop to my Laptop, but even restoring back to the original location (Desktop) doesn’t work and keeps giving me this error, but only on some files not all.

Are both computers windows OS?  If so try to retrieve the files to an specific folder since the laptop wont have the same root directory as the desktop.

If you have tried that already, format the drive and remove all the information on the drive and make sure that the software is updated in both computers.  and try that again.