WD 1TB My Book no longer accessable

Three days ago I went to access my external WD 1TB hard drive and found I could not, When I clicked on it to open it asked me if I wanted to format. (I have 450GB of data already on this device). The bars on the front that normally tell you how full your device is, are no longer on. the white dot lot under the lock light is on and occassionally flashing every once in a while. (No the drive never had a password on it, nor has it ever been locked). Still it wants me to format when i click on it. 

I obviously said no i do not want to format. 

The device shows up on my comptuer, under USB mass storage in devices. I decided to try updating and reinstalling the driver. 

The driver on the WD virtual disk does not work (even tested on another computer and it came back as no driver found) so I downlaoded the driver and the ESE driver from WD. Installed both. Still no change.

Next I scoured the online forums and tried Test Disk to verify the disk condition and to repair the MRB if needed. Re-wrote it at a primary which is what it was.  Checked the disk for errors and any issues, didnt find any but still not change. 

I used WD datalife gaurd program, on initial screen it shows the My book 1110 as passing, but is blank instead of listing as a NTFS file device. Run a quick test DLDIAG which passed, then did the longer one which passed. Been trying ideas listed on the WD website. 

I next used EASEUS which tells me the file system is unformatted. Tried the wizard for partition recovery and was told I have no unallocated space. 

Used MiniTool Partition Wizard Home edition and ran partition recovery analysis on the drive. It shows the 930.86GB there as existing and it had listed NTFS boot sectors as missing or lost (there were a number of them being shown, this has always only been a storage device no a main boot drive) I went back and select fidn and fix errors automatically and re-ran the scan. so far its at 56% with nothing else coming up, so it would be safe to assume it fixed the NTFS Boot missing lost flag, but still my drive is not accessable, but the fiel system in Minitool lists it as NTFS, but status as none, with 100% data used. 

Next I am going to be trying a data recovery program, (free version) just to see if the data can still be seen on it. I dont want to format the drive and risk losing all the data I have on there, years worth of work and data on the drive. I am fully open to someone who has dealt with the problem and solved it. 

Something else you can try a Linux Live CD. Download one and burn to disk and boot from that. Sometimes you can recover data that way.


I havent  ever tried linux, not sure what it is like really. Using EASUS data recovery wizard, its finding the files on the WD hard drive, just waiting for it to finish, its got about an hour to go