WD 1TB does not show up anymore on my Macbook desktop/finder


#1

I have been using WD 1TB external USB hard disk for 4 months with my Macbook with Tiger 10.4 on it. I have plugged in the disk after I purchased without any special formatting or anything, and it worked fine so far. It just took a while, about few minutes, for the Macbook to show it on the desktop every time I got it disconnected and connected again. However, this time, I can not see the disk on the desktop nor on the Finder no matter what. I have plugged it in and out several times, I have restarted the machine etc. Nothing works. The disk is quite empty and it works fine with the PC…no cable problem or and disk failure issue for sure. I can see the disk on the Disk Utility app, but I can neither verify nor mount it…Any suggestions would be very helpful…thanks in advance


#2

This sounds like a common partition issue. Mac OSX (especially Tiger and earlier) is very picky about the formatting on the drive. Since you can access your data on a PC, I would back everything up and than use WD’s Data Lifeguard Diagnostics (on the PC) to write zeros to the drive (you might want to do an extended test also to make sure you didn’t damage the drive).

Once this is done, reconnect it to the mac (without formatting it on the PC) and use Disk Utility to format/partition the drive using an MBR partition type and the DOS filesystem. This will ensure the drive is compatible with both PC and Mac.


#3

Here is the quick check:

from the “Disk Utility” application

Highlight the WD 1TB drive

Look at the “Partition Map Scheme”, Does it say GUID Partition Table? Master Boot Record?

If it said " Master Boot record".

The partition may be corrupted from moving back and forth between PC and Mac.

Unplug the WD 1TB external drive from your Mac computer.

Re-start the Mac computer.

Connect the WD 1TB to your Mac. If it recognize, go ahead back up your data to the Mac local hard drive.

You would need to re-partition and format the WD 1TB.

Here is an article found on the www.wdc.com/support about formatting the WD 1TB on Mac.

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=287&p_created=1023810756&p_sid=YGY3ZcUj&p_accessibility=0&p_redirect=&p_srch=1&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9NzEsNzEmcF9wcm9kcz0yMjgsMjYwLDI1MCZwX2NhdHM9MCZwX3B2PTMuMjUwJnBfY3Y9JnBfc2VhcmNoX3R5cGU9YW5zd2Vycy5zZWFyY2hfZm5sJnBfcGFnZT0xJnBfc2VhcmNoX3RleHQ9Zm9ybWF0IGZvciBNYWMgYW5kIFBD&p_li=&p_topview=1


#4

Hi,

Thanarath said “Look at the “Partition Map Scheme”, Does it say GUID Partition Table? Master Boot Record?”

Mine says GUID Partition Table. Other than that, I have the same issue korayki did. I am on a macbook that has a new motherboard as of a week ago - had the problem both before, and after that work was done. so, im pretty sure its the driv.e things were totally normally for a while, and i rarely move the drive, and a month or so ago i noticed the drive never appeared in my finder. disk repair found no problems either. but it works fine; its my iTunes and my TimeMachine and when connected, both of those apps work find so I am confused why finder can’t see it. i do have paralles on my machine but in general, i rarely run that and cannot remember ever having plugged this into a windows machine…

any help appreciated besides wiping/reformatting!

Brian


#5

So the WD 1TB drive is formatted with apple GUID file system.

iTune and Time machine are working fine.

Not showing up in the Finder.  Why?

Answer: 

Not really sure what caused that problem.

Suggestion:

You need to back up your data if you can.

Either using the Time machine or windows PC.

After that you need to download the WD Data lifeguard from here

http://support.wdc.com/product/download.asp?groupid=101&sid=3&lang=en

to check your drive condition.

You might need to let it write 0 to the whole drive then format it with your Mac to GUID file system.

FYI: Time machine only works with Apple files system. Not FAT32.


#6

I am having a similar problem with a 2TB My Book for Mac.

I am running Snow Leopard (10.6.2) on a Mac desktop (2 x 3 Ghz Dual-Core Intel Xeon with 8GB 667 MHz DDR2 FB-DIMM).

I was using this drive purely for Time Machine back-ups. It was working perfectly for a week when all of a sudden, the drive didn’t show up in Finder or Disk Utility. Instead, there is a DVD icon with the name, “WD SmartWare.” The contents of this DVD are - among other things - a “Drive Unlock” application and folders such as “Extras,” “User Manuals” and "WD Software.

I tried using the Drive Unlock program, but the pop-up window tells me that the drive is not locked. I am confused because I don’t know which drive it is referring to since it is not showing-up anywhere on my computer.

I have tried everything from restarting the machine, power it completely off, unplugging and plugging the drive back into the computer and changing the power supply from being on a surge protector to plugging it in directly to a wall socket.

I am freaking out a little bit because I am in desperate need of a really old Time Machine back-up, and i can’t see the drive anywhere.

It’s important to note that I have also tried using this drive on a Macbook with the same result.

Thanks in advance for your help.