WD 1001 FALS Black Hard drive disconnect or do not get recognized in Windows or BIOS


#1

First thing first, here some info on my system :

OS : Windows 7 Home Premium  x64 French

Processor : Intel Q9550

Motherboard : Gigabyte GA-EP45-UD3P v1.6

Memory : 2 x 2 gigs Corsair Dominator CM2X2048-8500C5D

Video card : ATI 5850

Hard Drives : 2 x 80 gigs Intel SSD G2 (not in RAID)

                       1 x WD1001FALS-00J7B1 1T Caviar Black

Optical Drive :  PLEXTOR PX-880SA SATA

  • Intel Chipset software accelerator has been installed.

  • BIOS, Windows and all component’s drivers are up to date. (BIOS firmware at least since January, I haven’t checked since)

  • BIOS Onboard SATA/IDE Controller has been set to IDE Mode (not AHCI)

  • Gigabyte’s Intel SATA RAID/AHCI and SATA2 Drivers were not installed (if something was needed, it’s the Windows 7 drivers that had been automaticaly installed)

Allright here is my situation, step by step :

  • Bought an WD1001FALS-00J7B1 Black SATA drive in january 2010 to put in the HTPC that I was building.

  • The drive was to be a secondary data drive, no OS on it.

  • After the computer was put together and OS installed, everything was fine with the Caviar Black drive.

  • Proceeded to copy my files from my old HDD to the new Caviar Black drive. No problem there.

  • After a couple of days (or maybe a week or two), access to files on the caviar black seems somewhat slow. I could hear some HDD noise activity. Not the big clickings of a defective drive, but something more quieter.

  • Figured that it was probably my imagination, decided to reboot and everything seems to be back to normal.

  • The a couple of days ago, I noticed that sometimes, when the computer came back from sleep, the my Caviar Black drive was missing. No other SATA devices had that problem.

  • Rebbooting the computer seems to solve the problem, but I knew something fishy was going on. I’ve decidded to deactivate all energy saving/sleep management in the OS to all my drives, including of course the Caviar.

  • I tought I had nailed the the problem, but after some time the drive disapeared again. Wasn’t in the list from the Administrative Tools either.

  • I had enought, I decided to reboot and copy back my files from the Caviar to a safer place. But the drive wasnt seen by Windows anymore. I ent to look in the BIOS, but the drive wasn’t detected either. Very strange.

  • I wanted to use the WD Diagnostic tool software but then again the drive wasn’t detected.

  • I then tried to use different SATA cable, plug the HDD in another SATA Port but nothing helped.

  • I also tried to connect the HDD in another computer, but the drive wasn’t detected.

  • After that, I tought my backup files were lost since I couln’t access to drive anymore.

  • I didn’t had enough time to do further tests. I was thinking that maybe the drive had physical damage, and since it was installed verticallly. on the side, that maybe move the drive back horizontally would make the drive accessible again for me to recover my files., but I knew I had to dismantel half of the computer casing (a Silverstone Crown CW02) to get to the Caviar HDD and I didnt had time to do that.

-So that bring me here, like 6 months later (I told you I didn’t had time!) I taken appart the computer case to remove the Caviar HDD, reformatted my main drive (an SSD), installed the OS. Everything was OK.

  • Then decided to connect the Caviar Black drive again, putted horizontally this time, crossing my fingers.

  • Surprise! The drive got recognized! I went ahead and move my files to another drive.

  • I’ve waited a couple of day. The Caviar Drive seemed to behave properly.

  • But a couple of days ago, the drive disappeared again. Rebooting solve the problem. I noticed taht it took a little longer time for the BIOS screen to get past the HDD detection.

So, I don’t think I can trust that drive anymore. I downloaded the WD Diagnostic tool software and I’m scanning the drive as of now. The Quick Test have passed without any error. I’m running actually the second test. I’m halfway through.

I didndt had the heart to dig through the forum or search in Google for a possible solutions. I know my way around computers, but sometimes I just don’t feel up for a fight and just want things to work out of the box! :wink:

So I’m asking you, knowledgeable people, what do you think about my Caviar Black HDD? Do you think it’s faultly or is it some settings within my system? I’m still waiting for the results of the advanced WD diagnostic tool scan. Something might be discovered there, hopefully.

At worst, I’ll have to RMA the HDD I think, but I wanted to get some input from you guys first!

Thanks in advance for you help and guidance!


#2

Well, I did the Quick and the Extended Tests and both finished without any error at all.

I was nearly hoping to find some errors to explain the symptoms the HDD gave me. I’m a bit puzzled…

I guess the only thing to do is to RMA the HDD now.


#3

Does the drive have the same issue within another computer?  Otherwise, have you tried changing the SATA port and power/data cables connected to the drive within your own computer?  If the issue follows the drive, by all means, replace the drive.


#4

Well when the drive wasn’t accessible from Windows and not visible from the BIOS (that was nearly in the beginning when I installed the drive in January), I then connected it to my “previous” computer. It too couln’t see the drive, Windows nor the BIOS. I can’t remember if I tried a different SATA cable back then. I twas thinking the the HDD went dead.

Like I said in my previous message, I only reconnected the drive a couple of weeks ago, and to my surprise it was visible from the BIOS and from Windows too. I then used WD Diagnostic Tool on it, all tests have passed (the Quick and Extented tests) without any error.

I then tried HD Tune Pro. I’ve made 3 complete scans so far :

The first time, the drive “disconnected” in the middle of the scan. The HDD disconnection is not frequent. I just can’t seem to be able to pinpoint an exact situation. So, in HD Tune Pro, in the Health Status Tab, some error were revealed (see below). It also revealed errors in the Error Scan Tab. The scan was unfinished of course.

The second time, errors in the Health status Tab were found again, with slightly higher numbers (see below). But strangely no error were found in the Error Scan Tab.

The third time, I’ve decided to use a different SATA cable on a different SATA port. Again, errors were found in the Health Status Tab (with slightly higher number) :

(05) - Reallocated Sector Count (damaged sectors) : 215
(C4) - Reallocated Event Count (sector replacement) : 215
(C5) - Current Prending Sector (unstable sector) : 1245

But still no error in the Error Scan Tab.

I’m puzzled. I’m just not sure if it’s not a motherboard/controller problem or if it’s really the HDD. It work “fine” most of the time (well actually it’s just sitting in the computer, I haven’t used it since I fear it may crash for good again). I did some Data transfert on it tho, just for testing. Sometime, it’s lighning fast, other times, the transfert seems unusualy slow.

I guess I could ask a friend to put it in his computer the HDD and see if he get a disconnecting drive or slow transfert rate too, but like I said it doesn’t happen often and seem to be completely random.

I think I’ll do that as my last test before making an RMA. It would be the logical thing to do, and If my friend have some problem with it (I’ll ask him to copy/delete a lot of mp3/movies files), then I guess it would be safe to say that the HDD have some sort of problems, even so the scans were not exactly conclusives.


#5

Have you used our diagnostic utility to check the drive?  You can also try the drive in another pc and see how it performs.

DLG Diagnostics

http://support.wdc.com/product/download.asp?groupid=608&sid=3&lang=en


#6

Yes, the first tool I used was of course the Data Lifeguard Diagnostic for Windows. As I said it didn’t report any error on both tests (the quick and extended ones).

But it doesn’t matter as of now. I wanted to give the HDD to my friend so he could test it in his own computer. I was planning do do this the weekend. But yesterday I decided to copy/move/delete a lot of files of differents size, to stress a little the HDD. I didn’t really did that before, I was just happy (and surprized) that the HDD started to “work” again, despite the disconnections problems.

Well, I think the HDD die on me last night while doing those copying/move/deleting files as a data transfert test. It felt like the HDD was even more slower than usual. The HDD disconnected again. I rebooted the computer and the HDD wasn’t available anymore (in Windows and the BIOS). Even worst, the HDD is not spinning anymore. I tried connecting it with another power cable with no success.

So I got an RMA resquest and I’ll be sending back to drive to it’s birthplace this afternoon. Enough troubleshooting for this HDD. I know when to stop when there is no more hope! :wink:

Hopefully the HDD won’t magically start to work again like it did for me a couple of weeks ago after month of inactivity so the RMA process will go smoothly without any problems.

Thanks for the help, but in the end it seems that the HDD decided to FINALLY make a clear stand on his health status! hehehe


#7

Sorry to hear that. 


#8

Oh well, hard drive failure happens. I was at least able to retrieve all my files. That’s the most important thing.

As for the HDD itself, it is still under warranty and if there is no problem with the RMA, I will have a brand new and working one pretty soon!