WAN Download Speed Is Slow

Tried to download an 100mb/1000mb file and the download speed is slow as in bytes per second.

Same when i try to apt-get update or install something…

Results from the  ifconfig eth0 |grep errors command

RX packets:2029 errors:0 dropped:0 overruns:0 frame:0
TX packets:1968 errors:0 dropped:0 overruns:0 carrier:0

i tried this ethtool -s eth0 speed 100 duplex full autoneg off and this   ethtool -s eth0 advertise 0x008
(<- also put in boot file) and rebooted, still the same.
Really dont know whats wrong, there are no dropped packets,no errors nothing and even doing a factory restore doesnt resolve it. Checked my router (running dd-wrt fw) and nothing is interfering with the mbl, there are no limits set.

Replaced internet cable with a brand new one, no result.

What can i do…

Output from  ethtool -S eth0

NIC statistics:
     rx_packets: 2549
     rx_bytes: 1691103
     tx_packets: 2303
     tx_bytes: 375752
     rx_packets_csum: 2470
     tx_packets_csum: 1185
     tx_undo: 0
     rx_dropped_stack: 2
     rx_dropped_oom: 0
     rx_dropped_error: 0
     rx_dropped_resize: 0
     rx_dropped_mtu: 0
     rx_stopped: 0
     rx_bd_errors: 0
     rx_bd_overrun: 0
     rx_bd_bad_packet: 0
     rx_bd_runt_packet: 0
     rx_bd_short_event: 0
     rx_bd_alignment_error: 0
     rx_bd_bad_fcs: 0
     rx_bd_packet_too_long: 0
     rx_bd_out_of_range: 0
     rx_bd_in_range: 0
     rx_parity: 0
     rx_fifo_overrun: 0
     rx_overrun: 0
     rx_bad_packet: 0
     rx_runt_packet: 0
     rx_short_event: 0
     rx_alignment_error: 0
     rx_bad_fcs: 0
     rx_packet_too_long: 0
     rx_out_of_range: 0
     rx_in_range: 0
     tx_dropped: 0
     tx_bd_errors: 0
     tx_bd_bad_fcs: 0
     tx_bd_carrier_loss: 0
     tx_bd_excessive_deferral: 0
     tx_bd_excessive_collisions: 0
     tx_bd_late_collision: 0
     tx_bd_multple_collisions: 0
     tx_bd_single_collision: 0
     tx_bd_underrun: 0
     tx_bd_sqe: 0
     tx_parity: 0
     tx_underrun: 0
     tx_sqe: 0
     tx_errors: 0

ifconfig output

eth0      Link encap:Ethernet  HWaddr 00:90:a9:b4:d5:f4
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::290:a9ff:feb4:d5f4/64 Scope:Link
          RX packets:3913 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3640 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1880568 (1.7 MiB)  TX bytes:1086011 (1.0 MiB)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:909 errors:0 dropped:0 overruns:0 frame:0
          TX packets:909 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:138854 (135.5 KiB)  TX bytes:138854 (135.5 KiB)

Nvm! resolved by disabling QoS…