Volume controle in app not working good

I bought a WD TV Live Streaming Media Player a few days ago and everything is working great, BUT the volume control on my android app-remote is not working good (everything else on the app works just fine). When I change the volume using the app, it seems as if there is a massive delay in actual volume change. And sometimes the sound can be pretty bad during this delayed change in volume.

I thought that this was a hardware problem and changed the unit, but my new one has the exact same problem!

Does anyone know if this is hardware or software related? And if it’s software-related - is it the app or the firmware that causes the problem?

I have the latest app for android and the latest firmware. I have also tried the app on two different android phones, but the result is the same…

There is not volume control from the remote app, not even the normal remote control has that. You might be confusing it with something else.

Edit: Oops, yes there is. :dizzy_face: it must control the volume digitally then.

Yes, there is a volume control on the remote app.  … At least on the iOS ones, there is… Not sure about Android.

"There is not volume control from the remote app, not even the normal remote control has that. You might be confusing it with something else.

Edit: Oops, yes there is. :dizzy_face: it must control the volume digitally then."

Well, this is the advantage of the app, and a very useful advantage if it would work properly.

“Click the Kudos star to say thank you for helpful posts and be sure to come back and ‘Accept as Solution’ under options for the post that solved your issue.”

I will, IF there is a solution…