Vista boots slowly after installing WD20EARS-00J2GB0


#1

(In these calculations I assume that Vista is loaded when the sidebar is visible and computer responds to commands quickly.)

Before installing this hard drive the computer booted in one and half minutes, but now it takes about four and half minutes. The desktop appears within a minute but then it takes over three minutes before the sidebar appears. And during those extra minutes the computer won’t respond quickly to commands, such as opening the Explorer. If I disconnect the WD20EARS, the computer boots again in one and half minutes.

I’ve tried both the MBR and GPT formatting with WD20EARS, but neither makes the computer start quickly. I’ve also installed Intel Rapid Storage Technology but it doesn’t make the computer boot any quicker. After the boot the hard drive works fine. I tested it with DiskBench and it was able to write one gigabyte file to WD20EARS at 120 MB/s.

Intel Rapid Storage Technology reports that the physical sector size of WD20EARS is 512 bytes. Isn’t it supposed to be 4096 bytes? Could this be the reason of the slow boot? My motherboard is ASUS P5Q-EM and I have installed its latest BIOS (version 2203). I haven’t plugged any jumpers to the hard drive and I haven’t run WD Align software.

Any suggestions on how to make the computer boot faster?


#2

I tried to solve the problem by reinstalling Vista. I installed it to this hard drive (WD20EARS-00J2GB0) and at first it seemed to work and my computer booted quickly.

Now the problem came back. I haven’t installed recently anything that could explain why the boot time quickly changed from less than one and half minutes to several minutes.

Does anyone have a clue what could cause this or how I could fix this?


#3

I would run a read benchmark.

http://www.hdtune.com/

Compare your results against other models:
http://www.hdtune.com/testresults.html

According to the specs, the max sustained data rate should be 110 MB/s.

I don’t know about Vista, but Windows XP will downgrade a drive’s performance from DMA mode to PIO mode if it detects more than 6 CRC errors.

DMA Mode for ATA/ATAPI Devices in Windows XP:
http://www.microsoft.com/whdc/device/storage/IDE-DMA.mspx

DMA reverts to PIO:
http://winhlp.com/node/10

Here are two SMART diagnostic tools.

HD Sentinel (DOS / Windows / Linux):
http://www.hdsentinel.com/

HDDScan for Windows:
http://hddscan.com/

See this article for SMART info:
http://en.wikipedia.org/wiki/S.M.A.R.T.

I’d look for UDMA errors in the SMART report. These are said to be the result of cabling or communications issues.


#4

Thank you for your reply. My computer has booted quicker lately, so I think I was too hasty to assume that the original problem would have come back.

Anyway, I did the HD Tune 2.55 tests. There are no damaged blocks and the status of all S.M.A.R.T. data is Ok. The Ultra DMA CRC Error Count line has the following values:

Current: 200
Worst: 200
Threshold: 0
Data: 0
Status: Ok

If I interpret it correctly, there has been no CRC errors, because the Data value is 0. But what does 200 mean as the Current and Worst value? I have two other hard drives and they both have 200 as Current and Worst, while their Data values are 1 and 3.


#5

The raw value is the actual count. The other numbers are normalised values. They represent a score out of 200, similar to a percentage health status. As the health worsens, the normalised values drop. If they hit the threshold, then the drive is deemed to have failed SMART. AIUI, in some (all?) models, the UDMA CRC Error Count is a rolling average, not a lifetime count, so the raw numbers may go up or down.