Video horribly stuttering while playing M2TS files (WD TV Live Plus HD)


#1

I have a bunch of Blu-Ray isos on my 7200 RPM 1 TB drive. My PC is Gigabit as with my Switch. Every device is running CAT6 ethernet cabling. When trying to play the Blu-Ray ISO, it says cannot play this file, but can play the movie inside. Perfectly fine with me. Everything starts out great, Image and sound quality are perfect. Then after about a minute and a half everything goes down south. The image stutters and the audio drops in and out. Thinking it might have to do with it being an ISO, I ripped the M2TS file out of there and played that directly. Well it did the same thing.

I’m on the latest firmware as well. My PS3 plays these files just fine.

Is anyone else experiencing this?

Everything is wired. No device is wireless.


#2

Welcome to the forums.

Due to the way the Live works, it cannot reliably play wirelessly files greater than 15mbps, so that’s most likely your problem.

You can either wire up your network, or you can compress the files (I highly recommend Handbrake, using the High Profile but change the output type to MKV).


#3

As I posted above, everything is running through CAT6. Nothing is wireless.


#4

Try connecting the 1 TB drive directly to the WD TV Live via USB. If that works, then you know you have a network problem. However, if it still doesn’t work, then you know the problem lies with the drive itself. I would then recommend to defragment the drive. Again, once the drive is defragmented and it still doesn’t work, then I would recommend to copy the file you’re having problems with to a USB drive. Finally, if that doesn’t work and you still experience stuttering, then it’s the file itself–in which case I would then recommend to reconvert the file. Like many of the recommendations on this site, I would convert the file to .mkv via Handbrake’s high profile leaving all other settings as is. Anyway, I hope this info helps.


#5

It’s not the file; nor the network. These same files work beautifully on the PS3.


#6

When you’re playing the file on your PS3, are you playing it via the same drive?


#7

Yes. Everything is 100% the same, except for the end device (PS3, WD TV Live Plus)


#8

If this Blu-Ray is “RAW,” meaning it’s not further compressed, it’s possible that the bit-rate still exceeds the WDTV’s capabilities (about 30 or so Mbit/sec)

This is a limitation of WDTV’s Samba implementation.


#9

Is there a way to get pass the WDTV’s Samba Implementation? Would going to the Live (Not Live Plus) with Custom Firmware fix this issue?


#10

I’ve been playing M2TS files from a USB connected WD portable 1TB drive on my Live Plus with no stuttering issues. I use ClownBD to remux with AC3 sound and everything works fine.

I have found one problem, though, with the M2TS files. Once in a while, when I go to play a M2TS file (doesn’t matter which one), I get a file not compatible error message. This is a random occurrence. The workaround for me is to choose a DVD ISO, start playing it, stop it, then re-select the M2TS file. It wil then play.

How are you creating your M2TS files?

Harlock


#11

I have my Blu-Rays ripped via AnyDVD. Once done, I open the blu-ray iso using daemon, and then move the m2ts file from the stream folder to harddrive. 

The fact remains though that the PS3 plays the M2TS files 100% perfectly, yet the WDTV Live Plus doesn’t. 

Everything is wired. Cat 6. Gigabit Switch. The only bottle neck I’ve discovered is that the WDTV Live Plus isn’t gigabit; but realistically that shouldn’t be a cause.


#12

I have discovered something. Normally I’ve been choosing the files to play on the WD TV Live Plus under the Network Shares option; it plays for a while then causes the issues.

However; when doing it under Media Share on the WD TV Live Plus; it plays just fine.


#13

But I really need to use Network Shares to access my DVD ISO and Blu-Ray ISO. With Media Share I’m unable to do so.


#14

WiiSmoker,  BRAD’s firmware lets you use NFS, but if your server isn’t NFS capable, then that won’t work for you.

I would recommend you Re-encode using Handbrake.   I’ve done that with my BD’s, and the results are indistinguishable from the originals if you use the “High Profile” preset, select the audio tracks you want, and re-mux to MKV.  Avatar went down to 13 GB in my case…  and it plays fine, wireless and wired both.

Or, just keep using your PS3’s for BDs…


#15

My server is Windows 7 64 Bit Home Premium. 

Does B-Rad work on WD TV Life Plus yet?


#16

I don’t think so, but this isn’t the forum to ask about that (B-Rad has his own forums).

Tony gave you the right advice – Handbrake your stuff as most of the rest of us are doing and be done with issues once and for all.


#17

That isn’t a solution. That is a band-aid


#18

WiiDSmoker wrote:

That isn’t a solution. That is a band-aid

A band-aid is first aid, the solution offered lasts for ever. It may be classed as a ‘major operation’ but not as a ‘band-aid’