Video Format invalid over DLNA

Hello All,

Looking for some advice here please…  Have a Sony bluray player kined up to mycould over a wireless network.  I was able to play my homemovies over DLNA and then recently I noticed all the videos are now  being reported as “invalid format” by the Bluray player.  I have hundreds of files that I used to be able to play now all of a sudden they are the wrong format?  I don’t think so.  Not sure when the change occured, it may have coincided with a firmware update but can’t be sure.

Also found that if I change the media receiver type in Twonky to “Generic Media Reciever” from “Sony Bluray” all works great, however whenever i restart the bluray player Twonky resets the media receiver type back to “Sony Bluray”.  Even if I uncheck “Enable sharing for new media receivers automatically” it still resets the reciever type.

Very frustrating…  I have had the cloud for almost 9 months now and never had any problems like this.

Additional info that may be helpfull:

Bluray player: Sony BDP-S590

My Cloud Firmware: 04.01.02-417

Video formats:  MP4, H264 or Xvid, AAC (like I said above they all worked before and will work now if I change to generic media reciever)

Any suggestions would be appreciated…

Hi MDA12

I have the same player and it is a pain to have to change the type every time you start it.

There is a way to change the Sony profile. You do have to enable SSH and change a file…this may or may not void your warranty. 

Enable SSH from the WD MYCLOUD Dashboard. While you are there, note the IP address your MYCLOUD is using.

Both will be under settings / network.

Using your ftp client, log into MYCLOUD…setting as follows. (filezilla is free if you need one)

Host: (the IP address your mycloud is using)

Port: (leave empty)

Protocol: Sftp -SSH

User: root

Password: welc0me

Navigate to the following folder…




On your mycloud, rename the file “Sony_Blu-Ray_Player.xml” to “Sony_Blu-Ray_Player.xmlbck”

(Right Click the file and choose rename)

On your computer, rename the file you downloaded “Sony_AV_Receiver.xml” to “Sony_Blu-Ray_Player.xml”

and upload it back into the Sony directory of your mycloud.

One last step…restart your twonky server…

Now, when you start your blu-ray, all files should be available again.

This setting will remain in place from now on. Note…a firmware update may return it to the original file. A reboot 

shouldn’t…but keep the modified copy on your computer for future use.


Thanks so much for the info, I suspected the issue was something like this.

Do you know when the Sony profile was changed?  I assume it was modified with one of the firmware updates.

Seems ridiculous to me that I have to do this to restore what I would consider basic functionality to the product.  Having a full time DLNA server on the network is one of the reasons I bought this product!

Hopefully WD will address this issue with an update soon.

Another question: Have you been able to get video thumbnails displayed using the BDP-S590?  I have never been able to get video or music icons to display, ever… 

Picture thumbnails work fine. 

Thanks again…

Hey, MDA 12

I am brand new to this MyCloud stuff and have the Sony Blu-Ray BDP-BX59, probably the same as yours and Though I can go in and find my files and the videos on it, when I try to play them it says “File corrupt or not unsupported”.  I really appreciated your response to jpeg1 as it seemed to be in great detail.  I just have one additional problem.  I can’t find anything called “Twonky” on my computer or on my Blu-Ray player.  Can I fix it without Twonky?  I haven’t tried any of the other things you suggested there because I’m waiting to get the answer to the Twonky question.

Again, Thanks for trying to be basic enough and in depth enough for even the real rank amateur like myself.

MDA…No, I haven’t ever had thumbs for video either. I lost the ability to play the files with a Sony firmware update. Sony states that it never guaranteed any file but mpeg would stream via DLNA and basically refuses to fix the problem. Simply stated, they don’t want people streaming their own content. Twonky uses the profiles Sony provides, It’s just lucky for us that they are editable.


We need more info. Are you using a MyCloud and is it just the single disk unit. This will not work on the EX2 or EX4 as the files are stored to a Ram Disk. If you are using an EX2 or EX4, it is possible to decompile the firmware, make the changes and recompile it…there are some post on the EX2 forum about it…THAT WOULD DEFINITELY VOID YOUR WARRANTY. 

If you don’t have a MYCloud, how are you streaming the files to your blu-ray? If you are streaming through Windows Media Player, there is probably not a fix. If you are streaming from your computer though, you can install a different dlna media server. You just need one that allows profiles to be edited. Twonky is available, but it’s $19.95. Plex and Serviio I believe are also easy to edit, but also come with a cost. XBMC (Now KODI) is free but will correctly stream your files. 


Thanks again for the info, this has been really insightful.

If that is true, that Sony is deliberately limiting the capability of they equipment for what I can only assume is concerns over piracy, I am very irritated.  I used to think of Sony as a solid electronics type company, the old failsafe, not flashy but reliable.  I have now bumped into “proprietary” type issues on several products, proprietary video formats is another one.  I wonder if they have considered the true cost of annoying customers?  I can tell you in the future I will definitely think twice before I buy another Sony product.  I will seek out a more “open source” type company and buy from them if I can.

Enough of the rant, I actually have more questions if you are willing to educate me…

  •  What caused the video format to stop being  playable over DLNA?  Was it the Mycloud firmware update or the Bluray player firmware update?

  •  Is it correct that the “Sony bluray player” profile that Twonky uses is supplied by Sony to Twonky and then ultimately to me as part of Twonky?