Very slow transfer rate LAN & USB

Hi everyone,

so I have this device (WD My Cloud Mirror - 4TB) for more than a month now and until now I didn’t manage to make it faster as 5MB/s. Last night it transferred with n faster than 800kb/s. Also I’ve tried to store the same movies through USB and took till morning (around 20GB).

Another problem that I have is that I cannot see any of my photos from outside the network, they don’t get downloaded - also I cannot upload something from outside. I think my internet speed dosen’t play any role here.

The transferred files were 200MB or larger. So the “small files problem” is not an argument.

My cloud is connected to the gigabit router through a CAT.6 cable.

I don’t know what to do more so I’m open to any suggestion. Btw, do you guys think the support would really help ?

Thanks in advance.

What was your MCM doing at the time, and what add-on apps have you installed (if any)?

The processor on the MCM isn’t very powerful, so actions like DLNA library cataloguing or anti virus scanning via the AV app take up a lot of the processor power and can make everything slow or even grind to a complete stop.

Hi,

First of all thanks for the quick reply.

Yes I have some apps, one of them is also the anti-virus : Anti-Virus Essentials

Other apps:
git - installed, but not in use
phpMyAdmin - in use
iceCast, Transmission - installed, but not in use

To answer your question, at the time the MCM was just copying the files and I stopped the media thing from settings.

In the end I can live with the slow transfer rate on the MCM of my data, but I am really interested in make it working remote.
Do you have any advices about this?

Thanks in advance

How are you trying to do your file transfer remotely? What method or app?

  1. I’ve tried direct USB.
  2. And I’ve mounted a share to my linux machine.

Just these two.

LE: I just wanted to check something else: when I’m copying some files from one share to another location on my share for 4.4GB takes like 15min -> the files are: ~ 200 MB

Another thing that may help is that my MCM is used as Raid0 3.5 TB + 500GB spanning - could that affect the system?

LE2: Also I observed something strange: when I start copying it starts with 15MB/s int the first 30s and then drops to 3MB/s and continues to drop the speed.

How are you doing the share to share copy? If you do it from another machine on your network, you’re not doing share to share, you’re doing share to machine to share, so traversing your network twice. If you’re machine is connected by wifi for example, then it can slow things considerably.

If you want to do share to share copy, the best way is to either use the web file viewer app built into the dashboard, or if you’re up to it, ssh into your MCM and use Linux terminal commands (cp mainly) to do it.

The drop-off is reasonably normal for networks, although yours does seem to be a larger drop than is common. I’d take a good look at your network and the traffic on it to see if that could cause it.

thanks, I will keep in mind and try this way.